1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Made4you.lu - Dein persönliches Geschenk!
    Information ausblenden

GPS-Das unbekannte Wesen

Dieses Thema im Forum "Fragen/Lösungen zu wlan/wep/gprs-wap(mms/sms)" wurde erstellt von Fossytux, 4. Oktober 2014.

  1. Fossytux
    Offline

    Fossytux Active Member

    Registriert seit:
    30. Juni 2014
    Beiträge:
    252
    Danke:
    237
    Geschlecht:
    männlich
    Moin zusammen, vielleicht kann mich mal einer erleuchten?
    Gerät ist ein UMI X3 mit einem völlig stabil laufendem 4.2.2.
    Aber das nur nebenher.
    Habe alle einschlägigen Tips,Apps gelesen und ausprobiert, auch mit WLAN aus.

    GPS funktioniert auch, Fix im Auto ca. Nach 6 Sekunden (Mittelwert aus Ingenieur mode).
    Als Navi Software habe ich nur Google Maps.Nun meine Beobachtungen die ich nicht deuten kann:
    1. Wenn ich stehe z.B. Ampel ,dann beginnt das Navi Bocksprünge zu mache, ist aber nicht so schlimm denn er fängt sich dann nach ein paar Sekunden.

    2. Auf freier Fläche also z.B. einem Hochplateau mit Freier Sicht ,gerader Strasse u.s.w. läuft er teilweise neben der Straße, oder er verliert den Satelliten komplett für mehrere Minuten.Die APP gegen Blitzerfoto's meldet dann auch kein GPS.

    Habe nun gestern eine längere Strecke mit der GPS Test APP gefahren, ständig mindestens 5 Satelliten im grünen Bereich und die Blitzer APP dazu an.
    Und Kein Ausfall auf der gesamten Strecke!

    Liegt es dann an Google Maps??
    Habe aber nicht vor nur zum probieren eine Navi APP zu kaufen.

    Also Frage ist warum verliert er auf freier Strecke seine Satelliten und warum verliert es sie nur wenn Google Maps läuft?

    Danke Euch im voraus.
     
  2. rWx
    Offline

    rWx Well-Known Member

    Registriert seit:
    24. April 2012
    Beiträge:
    3,726
    Danke:
    1,943
    Handy:
    Xiaomi Max 3/64
    Huawei Mate 7
    Huawei Mate S
    Xiaomi Redmi Note
    Google Maps funktioniert ja nur mit mobiler Datenverbindung. Hast du denn ausreichend Empfang zu der Zeit gehabt?

    Es gäbe auch die Möglichkeit eines Eintrages in der build.prop. Das behebt den Bug der falschen GPS Streckenmessung. Dazu muss dein Handy aber gerootet sein.

    Mit dem ES Datei Explorer oder build.prop Editor die /system/build.prop öffnen, und unten folgende Zeile hinzufügen:

    dalvik.vm.execution-mode=int:fast

    Das wäre aber nur eine Möglichkeit, falls alle anderen Tweaks oder Mods nicht funktionieren. Beim bearbeiten der build.prop sollte man auch sehr vorsichtig sein! Falsche Einträge können im Bootloop enden!
     
  3. lauterohre
    Offline

    lauterohre Skynet is online

    Registriert seit:
    10. August 2012
    Beiträge:
    393
    Danke:
    726
    Handy:
    Atom Z2580
  4. Fossytux
    Offline

    Fossytux Active Member

    Registriert seit:
    30. Juni 2014
    Beiträge:
    252
    Danke:
    237
    Geschlecht:
    männlich
    1. Schnelle Datenverbindung (Vodafone) mit Speed und genug Daten hab ich dabei

    2. Der genannte Eintrag ist drin, root sowieso

    Danke
     
  5. rWx
    Offline

    rWx Well-Known Member

    Registriert seit:
    24. April 2012
    Beiträge:
    3,726
    Danke:
    1,943
    Handy:
    Xiaomi Max 3/64
    Huawei Mate 7
    Huawei Mate S
    Xiaomi Redmi Note
    Dann teste am besten eine andere Navi App. Bei mir funktioniert Google Maps tadellos, auch ohne build Eintrag und irgendwelche Mods ;)

    Edit: Den GPS Fix von @Ora hast du auch per Recovery installiert? Der überschreibt die originale gps.conf durch eine angepasste (NTP Server).

    via Xiaomi Redmi Note Pro
     
    Ora sagt Danke für diesen hilfreichen Beitrag.
  6. Ora
    Offline

    Ora Teste mit subjektiver Wahrnehmung

    Registriert seit:
    22. Februar 2013
    Beiträge:
    9,352
    Danke:
    6,383
    Handy:
    LeEco Le Max 2 (X820) <- Arbeitstier
    ELE Vowney Lite <- Kamerareferenz
    Leagoo Elite 1 <- Frau
    zenFone 2 <- Videokamera Monitor
    Meine Beobachtungen zu Google Map:

    1. Der GPS Signalpegel muss ausreichend groß sein. Denn auch 4 kleine bringen kurzzeitig mal einen GPS Fix (Ortsbestimmung) zustande.
    2. Bei schnellen Richtungswechseln muss der Fix stabil bleiben oder in kürzester Zeit wieder hergestellt sein (dreht mal das Handy um 90 Grad, dann seht Ihr es.)
    3. Mein Tweak kann den Fix beschleunigen und etwas genauer machen, aber hat keinen Einfluss auf den Pegel des Empfangssignal.

    4. Treten in Stabilität und Pegel Unzulänglichkeiten auf, gleicht das ein OFF-line Navi allein schon durch die Option "Strasse folgen" einigermaßen aus.

    Fazit: Helfen keine Soft- oder Hardware Tweaks, dann versucht Euer Glück mit einem Off-Line Navi Programm. Gute Erfahrungen habe ich bei meinem Outdoor Handy A9 mit der app Be-on-road gemacht. Gibt es für viele Länder auch Karten zum Downloaden.

    Screenshot_2014-10-04-12-56-12[1].png hier zum Download
     
    Luky sagt Danke für diesen hilfreichen Beitrag.
  7. Fossytux
    Offline

    Fossytux Active Member

    Registriert seit:
    30. Juni 2014
    Beiträge:
    252
    Danke:
    237
    Geschlecht:
    männlich
    GPS.conf habe ich auch schon ausgetauscht.

    Aber Danke
     
  8. Fossytux
    Offline

    Fossytux Active Member

    Registriert seit:
    30. Juni 2014
    Beiträge:
    252
    Danke:
    237
    Geschlecht:
    männlich
    So, habe heute mal für eine kürzere Strecke, ca 0,5h, mit einer offline Navi APP getestet, also fast Tadel los.
    Mus ich nächste Woche nochmal mit einer längeren Fahrt verifizieren.

    Habe mir nach einem Tip hier im Forum nun folgendem Zusammenhang zusammen gereimt:

    Problem ist bei meinem UMI X3 eine schlechte Trennung/Abschirmung der HF Wege vom Handyteil zu den anderen Komponenten (Stichwort auch das Problem Rauschen UMI X3) .Google Maps das ständig die Karten und dazu die Daten für die Verkehrssituation nachlädt bedingt also ständig Funkverkehr.
    In der Stadt mit guter Versorgung sind mit UMTS die Daten schnell nachgeladen.Außerhalb der Stadt und weniger Sendemasten steigt die Sendeleistung an, dazu das runter schalten auf Edge und damit längere Sendezeiten.Und dabei stört das Sendeteil den GPS Empfang.

    So meine Vermutungen.
     
  9. AltF4
    Online

    AltF4 Active Member

    Registriert seit:
    18. April 2013
    Beiträge:
    267
    Danke:
    151
    Handy:
    Lenovo K3 Note
    Sony Xperia Z2
    uleFone Be Pro
    Sony Xperia Z Ultra
    Kingzone K1 turbo
    JIAKE X3s
    Vifocal W92
    Meiner Meinung nach spielt die Android Version selbst auch eine Rolle. Bei meinem Jiake X3s war die Navigation mit der 4.2.2 ROM, mit der ich es bekommen habe, ebenfalls immer sprunghaft.

    Nachdem das update auf 4.4.2 raus war, war die Navigation aller erste Sahne.

    Mein Kingzone K1 turbo hat noch ein 4.2.2 ROM, die Navigation ist eher ungenau, trotz tweaks.

    Das Blackview Crown von meiner Frau hat Android 4.4.2, die Navigation läuft out of the box stabil.

    Als Software verwende ich immer Navigon Select, damit die Ergebnisse vergleichbar bleiben.
     
  10. Fossytux
    Offline

    Fossytux Active Member

    Registriert seit:
    30. Juni 2014
    Beiträge:
    252
    Danke:
    237
    Geschlecht:
    männlich
    Da sind sie wieder meine drei Probleme.....

    Kein 4.4 für UMI X3!
    Kein 4.4 für UMI X3!
    Kein 4.4 für UMI X3!

     
    Erbsenmatsch sagt Danke für diesen hilfreichen Beitrag.
  11. Joe_User
    Offline

    Joe_User Well-Known Member

    Registriert seit:
    1. Juli 2014
    Beiträge:
    795
    Danke:
    1,529
    Geschlecht:
    männlich
    Das Smart E5 und das UMI C1 haben beide Kitkat und Navigation ist trotzdem fürn Popo. ;)

    Ich bringe als Grund für die unterschiedlichen Testfahrten einfach mal das Wetter ins Spiel. Bei schwachem Pegel fällt jede einzelne Wolke ins Gewicht.

    Hier im Forum ist irgendwo ein Thema versteckt, wo es um GPS Verstärker geht. Vereinfacht erklärt, pappt das Teil auf dem Autodach und leitet die Signale verstärkt in den Fahrzeuginnenraum. Damit mutieren sogar Chinaböller, welche vorher mit Mühe und Not 4 Satelliten empfangen haben, zu wahren GPS-Monstern. IMHO gibt es keinen besseren Beweis dafür, dass bei der GPS Qualität einzig und allein die Antenne ausschlaggebend ist. Wären es Unterschiede im Chipsatz, oder der Android Version, dann würde die schlichte Verstärkung des Signales, nicht solche krasse Steigerung der Empfangsleistung verursachen.
     
  12. AltF4
    Online

    AltF4 Active Member

    Registriert seit:
    18. April 2013
    Beiträge:
    267
    Danke:
    151
    Handy:
    Lenovo K3 Note
    Sony Xperia Z2
    uleFone Be Pro
    Sony Xperia Z Ultra
    Kingzone K1 turbo
    JIAKE X3s
    Vifocal W92
    Das kann ich so nicht durchgehen lassen, bei meinem alten Defy spielt das alles keine Rolle, die Navigation geht immer!!!


     
  13. N2k1
    Online

    N2k1 Well-Known Member

    Registriert seit:
    8. Juni 2010
    Beiträge:
    4,122
    Danke:
    938
    Handy:
    Elephone P7000
    Elephone P8
    Und was hat ein TI OMAP 3610 nun mit MediaTek Chipsätzen zu tun?
     
  14. AltF4
    Online

    AltF4 Active Member

    Registriert seit:
    18. April 2013
    Beiträge:
    267
    Danke:
    151
    Handy:
    Lenovo K3 Note
    Sony Xperia Z2
    uleFone Be Pro
    Sony Xperia Z Ultra
    Kingzone K1 turbo
    JIAKE X3s
    Vifocal W92
    Ich habe mich eigentlich auf den Einfluß des Wetters bezogen. Das Mediatek Chips im Gegensatz zum TI OMAP 3610 in dieser Beziehung schlechter sein sollen, kann ich mir nicht vorstellen.

     
  15. Joe_User
    Offline

    Joe_User Well-Known Member

    Registriert seit:
    1. Juli 2014
    Beiträge:
    795
    Danke:
    1,529
    Geschlecht:
    männlich
    Design- und Montagefehler bei der Antenne sind völlig unabhängig vom verwendeten Chipsatz.
     
    Ora sagt Danke für diesen hilfreichen Beitrag.
  16. Ora
    Offline

    Ora Teste mit subjektiver Wahrnehmung

    Registriert seit:
    22. Februar 2013
    Beiträge:
    9,352
    Danke:
    6,383
    Handy:
    LeEco Le Max 2 (X820) <- Arbeitstier
    ELE Vowney Lite <- Kamerareferenz
    Leagoo Elite 1 <- Frau
    zenFone 2 <- Videokamera Monitor
    Jede einigermaßen sachliche der unzähligen GPS Diskussion kommen letztendlich immer zum obigen Ergebnis:)
    Die Konstruktion der Antenne und deren Kontaktierung sowie störende Abstrahlungen des eigenen Handy aufgrund schlechter Abschirmung sind die Ursache für schwaches GPS:)

    mobile via T1
     
    Joe_User sagt Danke für diesen hilfreichen Beitrag.
  17. Fossytux
    Offline

    Fossytux Active Member

    Registriert seit:
    30. Juni 2014
    Beiträge:
    252
    Danke:
    237
    Geschlecht:
    männlich
    Was mir trotzdem nicht so klar ist:

    Jedes alte TimTim Navi ,10 Jahre alt, hat keine Probleme nach dem ersten Fix die Satellit en zu halten, egal mit welcher Wolke. Und ich habe auch gelesen das chinesische GPS Mäuse, auch ein paar Jahre alt, problemlos funktionieren.
    Wieso gibt es dann hier immer diese Probleme.
    Und wie man eine GPS Antenne im Handy designt und einbaut sollte den chinesischen Entwicklern klar sein ( die haben sicher mal ein Samsung oder LG demontiert)
    Oder wird GPS in China im Handy nicht gebraucht und dem zufolge diese Funktion als zweitrangig angesehen?
     
  18. AltF4
    Online

    AltF4 Active Member

    Registriert seit:
    18. April 2013
    Beiträge:
    267
    Danke:
    151
    Handy:
    Lenovo K3 Note
    Sony Xperia Z2
    uleFone Be Pro
    Sony Xperia Z Ultra
    Kingzone K1 turbo
    JIAKE X3s
    Vifocal W92
    ich habe mir eben noch mal das Video mit der externen GPS Antenne bei Zoppomobilshop angesehen. Die Signalstärke die dort mit der externen Antenne erreicht wird (zwischen 30 und 40), die habe ich mit dem Kingzone K1 turbo auch. Es werden sogar mehr Satteliten gefixt (meistens 11). Trotzdem ist die Navigation unzuverlässig. Die Architektur der Antenne und die Signalstärke scheinen nicht das Problem zu sein.

    Was mich immer wieder wundert ist, das die Navigation sich immer anders verhält. Wenn ich täglich meine 35km zur Arbeit fahre, dann schalte ich zum testen die Navigation immer ein. An manchen Tagen ist das Ergebnis tadellos, an anderen Tagen bewegt man sich laut Navi permanent abseits der Straße. Es wurden aber keine Einstellungen oder sonstiges verändert. Man kann auch nicht sagen das die Navigation bei Sonnenschein immer besser ist als bei bewölktem Himmel.

    Wenn ich mal den cache und dalvik lösche, die EPO Dateien neu runter lade, dann funktioniert die Navigation immer zufriedenstellend. Am nächsten Tag schon nicht mehr. Meine Vermutung das es bei KitKat besser funktioniert, stützt sich auf den ART Runtime Compiler von KitKat. Wenn bei manchen KitKat ROMs die Navigation nicht funktioniert, dann laufen die wahrscheinlich noch mit Dalvik (läßt sich ja umschalten).

    Gruß
    AltF4
     
  19. Ora
    Offline

    Ora Teste mit subjektiver Wahrnehmung

    Registriert seit:
    22. Februar 2013
    Beiträge:
    9,352
    Danke:
    6,383
    Handy:
    LeEco Le Max 2 (X820) <- Arbeitstier
    ELE Vowney Lite <- Kamerareferenz
    Leagoo Elite 1 <- Frau
    zenFone 2 <- Videokamera Monitor
    @AltF4: Liegt die EPO.dat im KK jetzt nicht mehr in /data/misc? Sowohl beim iOcean X8 (4.2.2) als auch beim MLAIS Note Pro (4.4.3) wird EPO nicht mehr genutzt!
    Und beide habe das von mir geschilderte gute GPS Verhalten:)
    EPO ist eine Krücke:( Die Standardserver fast nie erreichbar. AGPS schränkt ja hinreichend die Anzahl der Suche der Satelliten ein. Oder?
     
  20. lauterohre
    Offline

    lauterohre Skynet is online

    Registriert seit:
    10. August 2012
    Beiträge:
    393
    Danke:
    726
    Handy:
    Atom Z2580
    Hmm, mein Eindruck ist das es Apps gibt die sich negativ auf den GPS-Empfang auswirken. Benutze ich z.B. die App GPS-Marker dann funktioniert hinterher der GPS-Fix mit anderen Apps die GPS nutzen nur noch sehr langsam und dann auch nur ungenau. Abhilfe schafft dann erst ein Neustart.
    Sind EPO-Daten noch herunterzuladen, hab' ich schon ewig nicht mehr hingekriegt.(mit unseren MTKlern)
    Bei meinem ZTE(Intel Z2580) funktioniert das GPS eigentlich sehr gut. Hin und wieder brauchs zum ersten Sat-Fix dann ein bischen Zeit dann aktualisiere ich die AGPS Daten mit der APP GPS-Test, dann geht der Fix wieder unmittelbar.