1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Made4you.lu - Dein persönliches Geschenk!
    Information ausblenden

Kein Kompass im Star GT-i9300 MT6577 vom Cect-Shop??

Dieses Thema im Forum "Hardware/Zubehör (Speicherkarte/Headset/Akku/etc.)" wurde erstellt von PK1000, 9. September 2012.

  1. PK1000
    Offline

    PK1000 New Member

    Registriert seit:
    31. August 2012
    Beiträge:
    11
    Danke:
    0
    Handy:
    Tinji I9300 Mtk6577 Mobile Android 4.0
    Hallo Leute,

    wer hat auch das Star GT-i9300 MT6577 vom Cect-Shop und kann mir mal sagen ob der Kompass funktioniert?
    Bei mir hab ich schon alle möglichen Kompass-Apps ausprobiert - nichts erkennt ihn... hat das Teil denn keinen?

    Im Recovery-Mode erkennt er den Kompass (M-Sensor) auch nicht.
    Ich vermute, dass vielleicht irgendwelche Systemdateien fehlen, hab nämlich alle China-Apps mit dem Root-Uninstaller deinstalliert.

    Würde mich über positive Rückmeldungen sehr freuen :)

    PS: Das "Star GT-i9300 MT6577" ist baugleich (zumindest äußerlich), mit dem "Tinji GT-i9300 MT6577"
     
    Zuletzt bearbeitet: 10. September 2012
  2. CECT-SHOP.com
    Offline

    CECT-SHOP.com New Member Sponsoren

    Registriert seit:
    10. August 2011
    Beiträge:
    13
    Danke:
    1
    Handy:
    Sie finden bei uns eine sehr große Auswahl von Smartphones, Tablets und Zubehör.
    Hallo!

    Morgen kommt das Update ohne chinesische Apps, am besten Mal dieses verwenden, werden wir u.a. hier auf Chinamobiles.org zur Verfügung stellen. Evtl. löst dies ja das Kompass Problem.
     
  3. PK1000
    Offline

    PK1000 New Member

    Registriert seit:
    31. August 2012
    Beiträge:
    11
    Danke:
    0
    Handy:
    Tinji I9300 Mtk6577 Mobile Android 4.0
    Hallo,

    find ich ja toll, dass sich der CECT-Shop selbst hier meldet! :thumb_up:

    Ich weiß jetzt leider immer noch nicht, ob das Smartphone einen Kompass hat?!

    Ich werde das Update ausprobieren, mal schauen was es bringt...
     
  4. anat_fried
    Offline

    anat_fried New Member

    Registriert seit:
    28. Dezember 2009
    Beiträge:
    2
    Danke:
    0
    Handy:
    A008
    Hardware Probleme mit MTK6577 i9300

    Wie sieht es mir der Kamera in Ihrem neuen Update? Wird ihre Funktionalität auch verbessert. Autofokus funktioniert bei meine gar nicht. Besser gesagt, es funktioniert, aber zum Fotografieren werden unscharfe Einstellungen gewählt.
     
  5. PK1000
    Offline

    PK1000 New Member

    Registriert seit:
    31. August 2012
    Beiträge:
    11
    Danke:
    0
    Handy:
    Tinji I9300 Mtk6577 Mobile Android 4.0
    Also bisher habe ich von dem "Update" noch nichts gesehen. Vielleicht weiß ja von euch einer wo das gepostet wurde?!
    Von CECT höre ich auch nichts mehr...
    Ich habe lediglich Taiwan 101 V03 aufgespielt, oder meinen das alle mit den angekündigten Update?!

    @anat_fried
    Also bei meinem Gerät habe ich bisher mit dem Autofokus keine Probleme gehabt, evtl. ein Hardwareproblem mit deiner Kamera??

    Kann mir denn keiner bei meinem Kompass-Problem helfen? Ihr müsstest dafür doch nur mal kurz eine Kompass-App ziehen.
    Mein Aufruf richtet sich an die Besitzer eines Star/Tinji GT-i9300.
    Ihr würdet mir damit echt helfen!
     
  6. a-wei
    Offline

    a-wei Active Member

    Registriert seit:
    30. Juli 2009
    Beiträge:
    413
    Danke:
    79
    Geschlecht:
    männlich
    Handy:
    No1 s7

    Hoffentlich bald das UMI Zero
    Hallo wo hast du die Taiwan ROM her und wie hast du die installiert ??

    Danke im vorraus gruß andy
     
  7. N2k1
    Offline

    N2k1 Well-Known Member

    Registriert seit:
    8. Juni 2010
    Beiträge:
    4,122
    Danke:
    938
    Handy:
    Elephone P7000
    Elephone P8
    Auch wenn dieser Thread alt ist - wo ist denn das versprochene Update?
    Der Kompaß geht in keiner mir bekannten Version.
    Aber das Gerät hat auch selbst einen relativ starken Magnet (von hinten gesehen unten links)
     
  8. kawa0815
    Offline

    kawa0815 Member

    Registriert seit:
    19. Oktober 2012
    Beiträge:
    84
    Danke:
    17
    Handy:
    GT-S9300
    Ich denke, der Chip ist nicht verbaut. Ich habe mal die Kernelmodule manuell geladen. Keines der Module erkennt den
    Kompass-Chip.

    kawa
     
  9. N2k1
    Offline

    N2k1 Well-Known Member

    Registriert seit:
    8. Juni 2010
    Beiträge:
    4,122
    Danke:
    938
    Handy:
    Elephone P7000
    Elephone P8
    Der Chip ist definitiv auf meiner Platine.
    Woher hattest Du denn das passende Kernel-Modul?
     
  10. kawa0815
    Offline

    kawa0815 Member

    Registriert seit:
    19. Oktober 2012
    Beiträge:
    84
    Danke:
    17
    Handy:
    GT-S9300
    Aus einem ROM vom NEWMAN N1.
    Das hat auch Kernel 3.0.13 , ist mit gcc4.4.3 compiliert und da funktioniert der Kompass.
    kawa
     
  11. N2k1
    Offline

    N2k1 Well-Known Member

    Registriert seit:
    8. Juni 2010
    Beiträge:
    4,122
    Danke:
    938
    Handy:
    Elephone P7000
    Elephone P8
    Wenn ich mich nicht irre, ist im Newman ein AMI304 - im GT-i9300 ein AMI306.
    der 304 ist quasi ein ak8972 bzw. ak8974 - leider nicht (ganz) passend zum 306.
     
  12. kawa0815
    Offline

    kawa0815 Member

    Registriert seit:
    19. Oktober 2012
    Beiträge:
    84
    Danke:
    17
    Handy:
    GT-S9300
    Ich hab hier die bin akmd8963 und akmd8975.
    Habe noch einmal nachgesehen, der Inhalt von /system/lib/modules vom Newman und meinem i9300 ist hinsichtlich der Modulbezeichnungen deckungsgleich. Was mir aufgefallen ist, es gibt keine sensors.conf.

    Hast Du Dein Phone offen gehabt und den Chip gesehen.

    kawa
     
  13. N2k1
    Offline

    N2k1 Well-Known Member

    Registriert seit:
    8. Juni 2010
    Beiträge:
    4,122
    Danke:
    938
    Handy:
    Elephone P7000
    Elephone P8
    Ja, ich hatte es offen.
    Aber leider hab ich keine Photos gemacht.
    die akmd sind ja nur die daemons, die den Dienst stellen - ein Modul ist beim i9300 nicht zu finden - weshalb der deamon (selbst wenn es der 8975 ist) ins leere läuft.
     
  14. kawa0815
    Offline

    kawa0815 Member

    Registriert seit:
    19. Oktober 2012
    Beiträge:
    84
    Danke:
    17
    Handy:
    GT-S9300
    Das ist ja das Problem!

    Es gibt 2 Möglichkeiten.
    Die eine währe, MTK hat blöderweise den Treiber in den Kernel compiliert (was ich nicht glaube), oder die Module
    vom Newman und dem I9300 sind zwar namensgleich, haben aber den falschen Treiber (ami304 statt ami306).
    Ich vermute, dass der Sensor mit mtk_hwe.ko angesprochen wird.

    Die Spezifikationen für die beiden Chips findest Du hier:
    http://www.aichi-mi.com/3_products/081118ami304e.pdf
    http://www.aichi-mi.com/3_products/110127ami306e.pdf

    Auf den ersten Blick gibt es aber kaum Unterschiede.

    kawa
     
  15. N2k1
    Offline

    N2k1 Well-Known Member

    Registriert seit:
    8. Juni 2010
    Beiträge:
    4,122
    Danke:
    938
    Handy:
    Elephone P7000
    Elephone P8
  16. kawa0815
    Offline

    kawa0815 Member

    Registriert seit:
    19. Oktober 2012
    Beiträge:
    84
    Danke:
    17
    Handy:
    GT-S9300
    Ich hab jetzt mal einige Images von verschiedenen MTK 6577 durchgeforstet.
    Bei keinem fand ich ein Modul mit irgend einem Hinweis auf ami306 (sowas wie ami306.ko).
    Daher gehe ich immer mehr davon aus, dass der Treiber im Kernel steckt.
    Die ami306.c hatte ich bei meiner Sucherei schon gefunden. Die nützt nur nichts solange man keine .config
    hat und einen Kernel selber compilieren kann.
    Ich habe noch unter /system/lib/hw die sensors.mt6577.so gefunden. Die wird aber auch auf dem ami306 (kernel?)Treiber sitzen.
    Übrigens, der Orientation Sensor basiert auf dem ami306 und funktioniert daher auch nicht.

    kawa
     
  17. N2k1
    Offline

    N2k1 Well-Known Member

    Registriert seit:
    8. Juni 2010
    Beiträge:
    4,122
    Danke:
    938
    Handy:
    Elephone P7000
    Elephone P8
    Wo der Treiber auch hingehört.

    Die zu erstellen ist kein Problem - nur ohne Sourcen leider sinnlos.

    Korrekt.
     
  18. kawa0815
    Offline

    kawa0815 Member

    Registriert seit:
    19. Oktober 2012
    Beiträge:
    84
    Danke:
    17
    Handy:
    GT-S9300
    Mediatek hat doch die ganzen anderen Treiber in Module gepackt. Warum also nicht den für den ami306?
    Ist der Treiber im Kernel compiliert, können wir aufgeben, den Kompass zum Arbeiten zu bewegen.
    Ich hab hier gerade ein V1277 mit dem MTK6577. Da gibt es das gleiche Problem.
    Warten wir also bis irgendwer die MTK- Sourcen zur Verfügung stellt.


    kawa
     
  19. N2k1
    Offline

    N2k1 Well-Known Member

    Registriert seit:
    8. Juni 2010
    Beiträge:
    4,122
    Danke:
    938
    Handy:
    Elephone P7000
    Elephone P8
    Ich habe noch keine (sinnvollen) Mediatek-Sourcen gefunden.
    Sonst hätten wir einen eigenen uboot und einen eigenen Kernel (mit korrigierten Akku-Daten und der Möglichkeit des Übertaktens)
     
  20. kawa0815
    Offline

    kawa0815 Member

    Registriert seit:
    19. Oktober 2012
    Beiträge:
    84
    Danke:
    17
    Handy:
    GT-S9300