1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

MtkDroidTools - Erfahrungen - Tipps - Tricks - Download

Dieses Thema im Forum "Android Phones Tutorials" wurde erstellt von Ora, 2. Dezember 2013.

  1. Ora
    Offline

    Ora Teste mit subjektiver Wahrnehmung

    Registriert seit:
    22. Februar 2013
    Beiträge:
    9,343
    Danke:
    6,369
    Handy:
    LeEco Le Max 2 (X820) <- Arbeitstier
    ELE Vowney Lite <- Kamerareferenz
    Leagoo Elite 1 <- Frau
    zenFone 2 <- Videokamera Monitor
    So würde ich vorgehen:
    -- Handy ab vom PC
    -- damit Prüfen, ob schon adb Treiber installiert sind und diese damit runter schmeißen.
    -- PC neu booten
    -- dann Installation mit Administrator starten
    -- dann PC wieder neu booten
    -- dann Handy einschaltet mit USB Kabel (nicht an einem HUB) mit dem PC verbinden und erkennen lassen...

    Deine adb Utility arbeitet leider nicht stabil.
    --- Doppelpost zusammengefügt, 9. März 2014, Original Post Date: 9. März 2014 ---
    Dein Handy funktioniert aber schon normal und das USB Debugging in den Entwickleroptionen ist eingeschaltet?
    Dann starte bitte das ADB Fenster im Droidtool und gebe dort foldenden Befehl ein:
    Di Ausgabe müsste dann etwa so aussehen:
    Seriennummer device

    Es kommt auch vor, dass Du diesen Befehl mehrfach eingeben musst
    --- Doppelpost zusammengefügt, 9. März 2014 ---
    In Deinen MTK Droidfenster sieht man aussdem:

    - Dass Du oder der Auslieferer bereits Rootversuche unternommen haben
    - dass Du auf Deinem Handy eine Wiederherstellungsoption für das Standard Recovery bei jedem reboot hast (/system/recover-fom-boot.p)
     

    Anhänge:

  2. holybabel
    Offline

    holybabel Active Member

    Registriert seit:
    6. September 2012
    Beiträge:
    418
    Danke:
    59
    Handy:
    Star Q9000
    USB-Debugging ist aktiviert und ja, das Handy funktioniert sonst normal. Gerootet habe ich es bereits, das ist richtig.

    Was ist denn die erwartete Ausgabe bei adb devices? Bei mir kommt nur folgendes:

    Code:
    E:\Handy\Star Q9000\MtkDroidTools_v253>adb devices
    adb server is out of date.  killing...
    * daemon started successfully *
    List of devices attached
    0123456789ABCDEF		device
     
  3. Ora
    Offline

    Ora Teste mit subjektiver Wahrnehmung

    Registriert seit:
    22. Februar 2013
    Beiträge:
    9,343
    Danke:
    6,369
    Handy:
    LeEco Le Max 2 (X820) <- Arbeitstier
    ELE Vowney Lite <- Kamerareferenz
    Leagoo Elite 1 <- Frau
    zenFone 2 <- Videokamera Monitor
    Nun das sieht gut aus.
    Deshalb sind für mich die Anzeigen nicht erklärbar.
    Hat ein adb start-server eine Auswirkung auf die Anzeige?
    Wie hast Du gerootet?
    Was passiert, wenn Du den Root button drückst?
    Hast Du schon ein CWM Recovery.img versucht einzuspielen?
     
  4. holybabel
    Offline

    holybabel Active Member

    Registriert seit:
    6. September 2012
    Beiträge:
    418
    Danke:
    59
    Handy:
    Star Q9000
    Ich installiere mir gerade mal eine virtuelle Windows XP Maschine und versuch das darüber mal, vielleicht ist auch mein Win7 mittlerweile so verwurschtelt das es da irgendwelche Probleme gibt. Ich melde mich dann gleich nochmal.
     
  5. tommy0815
    Offline

    tommy0815 Well-Known Member

    Registriert seit:
    26. November 2010
    Beiträge:
    3,896
    Danke:
    808
    Handy:
    Samsung Galaxy Note 4
    Oppo Find 7
    das liegt an deinem ADB Treiber.....
    nimm am besten mal den aus meinem Thread!

    Edit: und so installieren wie es dort steht.
     
    holybabel sagt Danke für diesen hilfreichen Beitrag.
  6. Ora
    Offline

    Ora Teste mit subjektiver Wahrnehmung

    Registriert seit:
    22. Februar 2013
    Beiträge:
    9,343
    Danke:
    6,369
    Handy:
    LeEco Le Max 2 (X820) <- Arbeitstier
    ELE Vowney Lite <- Kamerareferenz
    Leagoo Elite 1 <- Frau
    zenFone 2 <- Videokamera Monitor
    Und nach einen "Geheimtipp:("...
    Da ich schon ewig mit adb arbeite habe ich in meiner Windows PATH Variable da Verzeichnis dieser damaligen Installation noch drin. Hat den Vorteil, dass ich auch adb ausserhalb vom Droidtool nutzen kann, aber den Nachteil, dass wenn rua1 mal mit seinem Werkzeug eine neeun Statz von adb dll mitbringt... es nicht sicher ist, dass im ADB Fenster vom Droid die richtigen gezogen werden... Irgenwie vergessen, welche Reihenfolge Windows nimmt.

    Prüf mal ob in Deinem Pfad vielleicht noch so etwas drin ist...
     
    yelupic sagt Danke für diesen hilfreichen Beitrag.
  7. tommy0815
    Offline

    tommy0815 Well-Known Member

    Registriert seit:
    26. November 2010
    Beiträge:
    3,896
    Danke:
    808
    Handy:
    Samsung Galaxy Note 4
    Oppo Find 7
    Der Fehler wird mit Sicherheit durch den "PDA" Treiber verursacht!

    Am besten mal alles was mit ADB zu tun hat deinstallieren und dann meinen Treiber verwenden und SO installieren wie es bei mir steht das klappt zu 100%
    Kenne auch nen paar die die gleichen Probleme haben, da kreuzen sich die ADB, weil er irgendwo falsch liest....

    also erstmal die Störenfriede eliminieren.
     
    holybabel und yelupic sagen Danke für diesen hilfreichen Beitrag.
  8. holybabel
    Offline

    holybabel Active Member

    Registriert seit:
    6. September 2012
    Beiträge:
    418
    Danke:
    59
    Handy:
    Star Q9000
    So, in der virtuellen XP Maschine hat es jetzt geklappt. Irgendwie ist mein Win7 schon so verwurschtelt, mal sehen wie ich das wieder hinbekomme.
     
  9. tommy0815
    Offline

    tommy0815 Well-Known Member

    Registriert seit:
    26. November 2010
    Beiträge:
    3,896
    Danke:
    808
    Handy:
    Samsung Galaxy Note 4
    Oppo Find 7
    (siehe ein Post über deinem) :)
     
  10. holybabel
    Offline

    holybabel Active Member

    Registriert seit:
    6. September 2012
    Beiträge:
    418
    Danke:
    59
    Handy:
    Star Q9000
    Juhu, endlich geht es auch unter meinem Win7 wieder.

    Danke tommy0815, ich habe alles deinstalliert und dann die Treiber aus dem Post genommen und damit geht es jetzt endlich wieder.
     
    tommy0815 und Ora sagen Danke für diesen hilfreichen Beitrag.
  11. Ora
    Offline

    Ora Teste mit subjektiver Wahrnehmung

    Registriert seit:
    22. Februar 2013
    Beiträge:
    9,343
    Danke:
    6,369
    Handy:
    LeEco Le Max 2 (X820) <- Arbeitstier
    ELE Vowney Lite <- Kamerareferenz
    Leagoo Elite 1 <- Frau
    zenFone 2 <- Videokamera Monitor
    Das usbdeview zeigt und hilft immer beim "Saubermachen":)

    Tapa talked
     
  12. blur
    Offline

    blur Active Member

    Registriert seit:
    17. Dezember 2013
    Beiträge:
    144
    Danke:
    71
    Geschlecht:
    männlich
    Handy:
    Moto X Play, Xiaomi Mi3, ZUK Z1,Nexus 7
    @holybabel, das hättest Du einfacher haben können ;)
    Die Tipps und Hilfen hier sind einfach super!
    Mir hatte diese USB-Treiber-Geschichte am Anfang auch viele Nerven gekostet.
    Erst mit usbdeview und dem Entfernen eines alten Path-Eintrags konnte ich das Problem lösen.
     
    Ora sagt Danke für diesen hilfreichen Beitrag.
  13. heintosz
    Offline

    heintosz Member

    Registriert seit:
    7. Dezember 2013
    Beiträge:
    56
    Danke:
    25
    Geschlecht:
    männlich
    Handy:
    HTC One X
    Goophone i5S
    Hi Leute,

    Ich habe eine Frage zum SP Flash Tool. Ich habe ein Xiaocai X800 (MTK6572) und würde es gern rooten. Habe bereits mehrere Telefone gerootet und sehr viel gelesen. Bin also nicht ganz unbewandert was das Thema root und flashen angeht.

    Hier mein Problem:
    Das Xiaocai X800 lässt sich nicht mit dem root Knopf rooten, also muss die umständliche Methode her (Tipp0 und Tipp12). Ich habe also ein backup mit Tipp0 gemacht (bzw. mit Hilfe von rua1 auf XDA, aber das ist ja das gleiche). Das ging soweit gut. Also der Schritt Tipp0 ist vollständig ausgeführt. Dann wollte ich das gepatchte recovery flashen (Tipp12) und bekam Fehlercode 8038. Den konnte ich beseitigen indem ich einige Angaben in der scatter file angepasst hatte. Dann mit angepasster scatter file nochmal geflasht und jetzt bekomme ich Fehlercode 1011: Nicht genügend Speicher.

    Leider hilft google nicht bei diesem Fehler, vielleicht kann mir hier jemand helfen?

    Also die gepatchte recovery ist definitief kleiner als 6.144KB und auch kleiner als die original recovery, darum verstehe ich den Fehler nicht. Hat den Fehler schon mal jemand gehabt oder kann mir anders helfen?

    Jegliche Tipps sind willkommen!
    Gruß heintosz

    PS: Das Telefon funktioniert nach wie vor einwandfrei aber halt ohne root.
     
  14. tommy0815
    Offline

    tommy0815 Well-Known Member

    Registriert seit:
    26. November 2010
    Beiträge:
    3,896
    Danke:
    808
    Handy:
    Samsung Galaxy Note 4
    Oppo Find 7
    was ich nicht verstehe. Du willst eine modifiziertes recovery flashen und meinst anschließend hast du root?
    Dazu musst du das gepatchte boot.img flashen. Evtl hast du dich ja lediglich verschrieben.
     
    Louis777 sagt Danke für diesen hilfreichen Beitrag.
  15. heintosz
    Offline

    heintosz Member

    Registriert seit:
    7. Dezember 2013
    Beiträge:
    56
    Danke:
    25
    Geschlecht:
    männlich
    Handy:
    HTC One X
    Goophone i5S
    Danke für die Antwort. Ich war der Meinung ich muss die recovery flashen, dann in die recovery booten und mit MTK Droid Tool rooten. So erklärt es zumindest rua1 hier: http://forum.xda-developers.com/showpost.php?p=38337401&postcount=5

    Aber wenn ich mit flashen der boot.img schon root bekomme, dann werd ich das mal probieren. Recovery hab ich eigentlich sowieso nicht nötig, root reicht mir.


    EDIT:
    Ok gerade getestet, gleicher Fehler.
     

    Anhänge:

    Zuletzt bearbeitet: 11. März 2014
  16. Ora
    Offline

    Ora Teste mit subjektiver Wahrnehmung

    Registriert seit:
    22. Februar 2013
    Beiträge:
    9,343
    Danke:
    6,369
    Handy:
    LeEco Le Max 2 (X820) <- Arbeitstier
    ELE Vowney Lite <- Kamerareferenz
    Leagoo Elite 1 <- Frau
    zenFone 2 <- Videokamera Monitor
    tommy0815 in seinem Root Thread und ich in meinen TIPP12 habe es in diesem Board beschrieben.
     
  17. heintosz
    Offline

    heintosz Member

    Registriert seit:
    7. Dezember 2013
    Beiträge:
    56
    Danke:
    25
    Geschlecht:
    männlich
    Handy:
    HTC One X
    Goophone i5S
    Ja, genau so wie in Tipp12 habe ich es ja gemacht (und da steht Recovery, nicht bootimg), aber dann bekomme ich eben den Fehler 1011. Ich werde es nochmal mit ein paar anderen Versionen von MTK Driod Tool und SP Flash Tool versuchen, vielleicht hilft das. Werde mir auch nochmal tommys root anleitung anschauen, vielleicht macht er was anders als ich und dann versuch ich das nochmal.
     
  18. Ora
    Offline

    Ora Teste mit subjektiver Wahrnehmung

    Registriert seit:
    22. Februar 2013
    Beiträge:
    9,343
    Danke:
    6,369
    Handy:
    LeEco Le Max 2 (X820) <- Arbeitstier
    ELE Vowney Lite <- Kamerareferenz
    Leagoo Elite 1 <- Frau
    zenFone 2 <- Videokamera Monitor
    Den Fehler hast Du an dieser Stelle bekommen?
     
  19. heintosz
    Offline

    heintosz Member

    Registriert seit:
    7. Dezember 2013
    Beiträge:
    56
    Danke:
    25
    Geschlecht:
    männlich
    Handy:
    HTC One X
    Goophone i5S
    Ja genau an der Stelle. Bin gerade dabei alles nochmal von vorne zu machen mit den neusten Versionen von beiden Tools und der Anleitung von tommy.

    Werde mich gleich nochmal melden, ob es damit funktioniert hat. Fingers crossed :)

    EDIT:
    Soweit so gut, aber jetzt krieg ich nen neuen Fehler: 1013 Com Port Open Fail. Es scheint nicht gerootet werden zu wollen. So hat sich ja noch keins meiner Geräte gesträubt...

    EDIT2:
    Es hat funktioniert!!
    Ich hatte erst das Readback mit der v5 von SP Flash Tool gemacht. Allerdings hat mit der Version der Download nicht funktioniert (Fehler 1013).

    Den Download hab ich dann mit v3 von SP Flash Tool gemacht und das ging ohne Probleme!! Vielen vielen Dank @OraChinaMobiles für die Tipps und @tommy0815 für den exzellenten Guide. Der ist wesentlich besser und ausführlicher als alles andere was ich bisher gesehen hab!!

    Noch eine kurze Frage zum Schluss: Muss ich jetzt noch superuser, terminal und busybox installieren oder ist das nicht nötig?
     

    Anhänge:

    Zuletzt bearbeitet: 11. März 2014
    Ora sagt Danke für diesen hilfreichen Beitrag.
  20. Ora
    Offline

    Ora Teste mit subjektiver Wahrnehmung

    Registriert seit:
    22. Februar 2013
    Beiträge:
    9,343
    Danke:
    6,369
    Handy:
    LeEco Le Max 2 (X820) <- Arbeitstier
    ELE Vowney Lite <- Kamerareferenz
    Leagoo Elite 1 <- Frau
    zenFone 2 <- Videokamera Monitor
    Das kann ich Dir ausdrücklich empfehlen. Ob Terminal ist Geschmacksache, busybox für mich ein muss.
    Ob der Booloader permanent offen bleiben muss (gepatche boot.img) ist übrigens hier die Option, nicht root im System;)