1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Made4you.lu - Dein persönliches Geschenk!
    Information ausblenden

MtkDroidTools - Erfahrungen - Tipps - Tricks - Download

Dieses Thema im Forum "Android Phones Tutorials" wurde erstellt von Ora, 2. Dezember 2013.

  1. Datscher
    Offline

    Datscher Member

    Registriert seit:
    25. Oktober 2011
    Beiträge:
    87
    Danke:
    15
    Geschlecht:
    männlich
    Handy:
    ZTE OpenC, FirePhone, Redmi 3, Hisense Sero7 pro
    Den hatte ich vor einiger Zeit mal installiert, geriet dann allerdings in Vergessenheit.
    Aber nun hab ich´s: Der "Droid Explorer" hatte eine extra "adb.exe" am Laufen - den gelöscht
    und alles ist ok.

    Vielen Dank für Deine Unterstützung, ich bin happy :party:
     
    Psiim_de und Ora sagen Danke für diesen hilfreichen Beitrag.
  2. Ora
    Offline

    Ora Teste mit subjektiver Wahrnehmung

    Registriert seit:
    22. Februar 2013
    Beiträge:
    9,352
    Danke:
    6,383
    Handy:
    LeEco Le Max 2 (X820) <- Arbeitstier
    ELE Vowney Lite <- Kamerareferenz
    Leagoo Elite 1 <- Frau
    zenFone 2 <- Videokamera Monitor
    calipo69 sagt Danke für diesen hilfreichen Beitrag.
  3. lernfabrik
    Offline

    lernfabrik New Member

    Registriert seit:
    14. April 2015
    Beiträge:
    5
    Danke:
    12
    Geschlecht:
    männlich
    Handy:
    Cube Talk 9X, Xiaomi Mi4c
    Hallo zusammen,
    ich besitze ein Cube Talk 9X U65GT mit32GB internem Speicher. Darin werkelt ein MT8392. Mir ist es wichtig ein funktionsfähiges Backup vom Ursprungszustand zu erstellen, da ich die folgenden Modifikationen vornehmen möchte: Repartitionierung des Speichers, Patchen eines Mods zur Anpassung der Helligkeit, Custom Recovery (TWRP) und Root.

    Ich habe mich in den letzten 3 Wochen zu diesem Thema sowohl hier als auch bei XDA-Developers, Android-Hilfe und vor allem bei Freaktab eingelesen. Meine Bookmark-Sammlung zu diesem Thema umfasst inzwischen ungefähr 50 Einträge mit HowTo´s, Tutorials oder gerätespezifischen Hinweisen. Leider war das wohl zu viel des Guten, denn inzwischen raucht mir der Kopf und ich weiß nicht mehr wo ich was gelesen habe.

    Maßgeblich für meine bisherigen Handlungen war dieses Forum, da es sehr ausführlich auf die notwendigen Grundlagen eingeht und Freaktab.com, da dort eine sehr aktive Community speziell für das Talk 9X anzutreffen ist.

    Das Tablet ist gerootet.

    So nun zu meinem Problem:
    Sowohl der „NVRAM/IMEI“ Button als auch der „Erstellen einer Scatterdatei“ Button sind ausgegraut und beim Erstellen der Backups wird kein Scatterfile erzeugt.
    DroidTools NVRAM.PNG DT-Blockmapping.PNG

    Folgendes ist bereits erfolgt:
    1. Gemäß Anleitung Basisfunktion 1 „Datensicherung“ habe ich ein Backup erstellt. Leider wird hierbei kein Scatterfile erzeugt! DT Backup Dateien.PNG
    2. Also habe ich gemäß Anleitung Offline eine Scatterdatei erzeugt. Diese beginnt allerdings nicht mit MT6592… sondern mit MT6582…
    3. Daraufhin habe ich in der MTKdroidTools.ini die Zeile SocToScatName um den Eintrag „,8392:6592“ erweitert -> ohne Erfolg, alter Name
    4. Mit dem unter 2 offline erstellten Scatterfile konnte ich das „prepare for Flashtool“ ausführen und habe auch den Ordner „!File_to_FlashTool“ erhalten, allerdings wieder ohne Scatterfile DT Files to Flash.PNG
    5. Soeben die TKdroidTools.ini aus dem Startpost ausprobiert, aber immer noch graue Buttons.
    Da ich zumindest das Blockmapping in DT einsehen kann, habe ich auch versucht ein Backup nach Basisfunktion 0 mittels ReadBack über SP FlashTool v5.1420.00 zu erstellen. Hierbei gab es aber Probleme.

    Wenn ich das Offline erstellte Scatterfile (MT6582..) verwende, erhalte ich folgenden Fehler:
    eigenes Scatter file.PNG

    Wenn ich ein Scatterfile aus der Datensammlung von Freaktab (von Brian aka 900supersport, config_version: 1.1.2) einsetze (MT6592..), erhalte ich folgenden Fehler:
    Scatterfile 900SS.PNG

    Also habe ich die Sicherung nochmal mit SPFT v5.1352.01 mit Brian´s Scatterdatei versucht und hatte Erfolg und die „ROM_“-Datei erzeugt. Nach der Aufbereitung mittels DT habe ich allerdings keine Preloader.bin. Darauf wird auch in der Anleitung hingewiesen. Liegt das evtl. an den Einträgen in den Scatterfiles? Ich habe die beiden Scatterdateien mal angehängt.

    Abschließend habe ich TWRP via SPFT geflasht und nochmals ein Backup mit TWRP erstellt.

    Meine Fragen:
    1. Ist eines meiner Backups im Notfall einsatzfähig oder habe ich nur Datenmüll produziert?
    2. Ich habe festgestellt, dass das Scatterfile essenziell für das ganze flashen ist. Wie komme ich an eine funktionierende Datei?
    3. Wieso hat in meinem Fall nicht eine Anleitung funktioniert wie sie sollte?
    Inzwischen habe ich die Repartitionierung vorgenommen und den Helligkeits-Mod gepatcht. Das Tablet läuft einwandfrei. Ich habe aber, wie geschrieben, ein ungutes Gefühl bzgl. meiner Backups.

    Sorry für den langen Post. Ich wollte aber alle Infos zur Verfügung stellen, in der Hoffnung, dass mir geholfen werden kann.
     

    Anhänge:

  4. altmann
    Offline

    altmann Yvan Eht Nioj

    Registriert seit:
    23. November 2008
    Beiträge:
    1,176
    Danke:
    2,761
    Geschlecht:
    männlich
    Handy:
    derzeit: Wiko Highway Star
    Ich kriege das Ding einfach mit dem elephone P6000 meiner Frau nicht zum laufen.

    Ausgangssystem ist Win7 64bit.

    Habe alle eventuell installierten USB-Devices mit usbdeview entfernt.
    Danach die aktuellen Treiber aus dem elephone-Forum gedownloaded und installiert. Dabei wurde ich oft darauf hingewiesen, dass die Treiber nicht signiert sind, ob ich sie trotzdem installieren will. Ist wohl ganz normal die Abfrage, habs installieren lassen.

    Jetzt die Batterie aus dem Telefon genommen und das Telefon mit dem PC per USB verbunden.

    Der PC erkennt das ganze auch als MT6xxx Preloader und installiert scheinbar die jetzt auf dem PC vorhandenen Treiber.

    Im Gerätemanager wird mir das Telefon dann auch angezeigt unter Ports, jedoch mit einem roten Haken und der Meldung "Fehler 10: Gerät kann nicht starten".

    Jetzt wird das Telefon auch weder beim MTK Droidtool noch beim SPFlashtool erkannt. Egal, ob ich jetzt die Batterie drin habe oder nix, da passiert nix.

    Wenn ich das Telefon abziehe, neu boote und dann wieder einstecke kommt einmal das "Klong"-Geräusch, dass ein USB-Gerät gefunden wurde, dann zeigt der Gerätemanager es auch für ein paar Sekunden an, und dann kommt direkt das nächste "Klong", dass ein USB-Gerät getrennt wurde. Und dann isses auch nicht mehr in der Liste.

    Das einer der Tools es überhaupt mal findet, habe ich noch nicht geschafft.

    Edit: Gerade nochmal die Treiber deinstalliert, rebootet, dann das Telefon ohne Batterie angeschlossen. Folgender Error tauchte auf:

    [​IMG]

    Hab die Verbindung aber nicht getrennt.. Irgendwie merkwürdig.

    Was mache ich falsch??
     
    Zuletzt bearbeitet: 27. Mai 2015
  5. Ora
    Offline

    Ora Teste mit subjektiver Wahrnehmung

    Registriert seit:
    22. Februar 2013
    Beiträge:
    9,352
    Danke:
    6,383
    Handy:
    LeEco Le Max 2 (X820) <- Arbeitstier
    ELE Vowney Lite <- Kamerareferenz
    Leagoo Elite 1 <- Frau
    zenFone 2 <- Videokamera Monitor
    Eigentlich nichts.
    der preloader wird nur für kurze Zeit im Geräte Manager angezeigt.
    Falls Du W 8.1 nutzt, musst Du den Rechner zum Installieren nicht signierter Treiber vorbereiten.
    Klappe mal Ports (Com&LPT) auf und beobachte was kurz angezeigt wird nach Anstecken ohne Batterie.

    Hast Du mal versucht, etwas zu flashen? Startet der rote Balken?
    Zeigt usbdeview denn jetzt den Preloader an und ist auch ein com Port zugeordnet?
     
    Zuletzt bearbeitet: 27. Mai 2015
    altmann sagt Danke für diesen hilfreichen Beitrag.
  6. altmann
    Offline

    altmann Yvan Eht Nioj

    Registriert seit:
    23. November 2008
    Beiträge:
    1,176
    Danke:
    2,761
    Geschlecht:
    männlich
    Handy:
    derzeit: Wiko Highway Star
    Danke schonmal für die Antwort.

    Ich schaue da hinterher zu Hause nochmal nach, bin gerade bei der Arbeit.

    Ein COM-Port wird angezeigt, wenn ich das richtig in Erinnerung habe.
    Nur wird das Telefon halt von MTK Droidtool nicht erkannt. Da steht unten in der Statusleiste gleich was vonwegen "Gerät nicht verbunden".
    Vorm flashen wollte ich damit eigentlich erst nen Backup machen..
     
  7. Ora
    Offline

    Ora Teste mit subjektiver Wahrnehmung

    Registriert seit:
    22. Februar 2013
    Beiträge:
    9,352
    Danke:
    6,383
    Handy:
    LeEco Le Max 2 (X820) <- Arbeitstier
    ELE Vowney Lite <- Kamerareferenz
    Leagoo Elite 1 <- Frau
    zenFone 2 <- Videokamera Monitor
    Getrennte Schuhe...
    MTK DT:
    - Entwickleroptionen USB Debugging on
    - ADB Treiber installieren
    - prüfen, ob nicht schon eine ADB Bridge läuft
    - USB Optionen mal auf USB Speicher stellen
    - ADB Konsolfenster öffnen und mal
    ADB kill-server
    ADB start-server
    ADB devices
    eingeben und schauen, ob ein Gerät erkannt wird.
     
    altmann sagt Danke für diesen hilfreichen Beitrag.
  8. altmann
    Offline

    altmann Yvan Eht Nioj

    Registriert seit:
    23. November 2008
    Beiträge:
    1,176
    Danke:
    2,761
    Geschlecht:
    männlich
    Handy:
    derzeit: Wiko Highway Star
    Ahhh, okay, dachte MTK Droidtool nutzt auch die Treiber. Habe ich entweder falsch verstanden oder zu schlampig gelesen ;)

    ADB-Verbindung sollte ich denke hinbekommen. Aber klar, wenn das Telefon ausgeschaltet ist und über den VCOM-Treiber läuft, interessiert das ein ADB-basiertes Tool wie MTK Droidtool natürlich nicht. Kein Wunder, dass der mir da nix anzeigt.

    Schonmal ganz lieben Dank für den Hinweis, dass sollte mich denke heute Abend schonmal etwas weiterbringen. Ich melde mich dazu nochmal.
     
    Ora sagt Danke für diesen hilfreichen Beitrag.
  9. altmann
    Offline

    altmann Yvan Eht Nioj

    Registriert seit:
    23. November 2008
    Beiträge:
    1,176
    Danke:
    2,761
    Geschlecht:
    männlich
    Handy:
    derzeit: Wiko Highway Star
    Okay, MTK Droidtool kommt per ADB aufs Handy, wie auch nicht anders zu erwarten.

    Wollte jetzt ein Backup machen, bekomme jedoch folgende Fehler im Status angezeigt:

    Code:
    Im System bereits verfügbar:  Android Debug Bridge version 1.0.26
    
    --->>> Connect to device <<<---
    --- FEHLER  :  --- TotalBytesPerChunk Not Found. Set default Page/Spare=2048/64 !!!
    --- Sicherungsverzeicnis auf dem Computer: J:\P6000\MtkDroidTools_v253_ML\backups\Elephone-P6000-02_150206_backup_150527-214754\
    --- Im Phone werden die Dateien in diesem Verzeichnis gespeichert: /mnt/sdcard/clockworkmod/backup/150527-214754/
    --- Wir erhalten Blöcke:
    - nodl_proinfo - FEHLER :  Zero file, no space left on device!
    --- Wir behalten die Ordnerinhalte beim Kopieren auf den PC
       - /data/nvram
       - /system
    --- Aufgabe endet mit FEHLER  ---
    Mich irritiert schon die Zeile "nodl_proinfo - FEHLER : Zero file, no space left on device!".
    Gerätespeicher erkennt er 8GB frei, auf der PC-Festplatte sind ca. 50GB frei. Sollte definitiv für ein komplettes Backup
    reichen.

    Er fängt auch an, die Verzeichnisstruktur am PC zu erstellen, bricht dann aber halt bei /system nach 1-2 Minuten ab.

    Kann ich da nicht einfach nen CWM-Recover irgendwie draufflashen und damit nen NAND-Backup machen? So war es zumindest bei meinem Samsung Galaxy S3.
    Dort konnte ich dann auch direkt über das CWM das Backup wieder zurückspielen, falls was schiefläuft.
     
  10. Ora
    Offline

    Ora Teste mit subjektiver Wahrnehmung

    Registriert seit:
    22. Februar 2013
    Beiträge:
    9,352
    Danke:
    6,383
    Handy:
    LeEco Le Max 2 (X820) <- Arbeitstier
    ELE Vowney Lite <- Kamerareferenz
    Leagoo Elite 1 <- Frau
    zenFone 2 <- Videokamera Monitor
    Das MTK DT eignet sich nur für SoC's bis MT6592 zur Bearbeitung und Datensicherung.
    Besser geeignet sind dazu Customer Recoveries, wie TWRP.
    Diese stehen fúr das P6000 zur Verfügung und müssen mit dem SP Flashtool auf das Handy gebracht werden. Allerdings eignen diese sich dann wiederum nicht für das OTA.
    Lese dazu mal mein Review. Ich habe hier alles Notwendige bereitgestellt und beschrieben.
     
    Zuletzt bearbeitet: 27. Mai 2015
  11. altmann
    Offline

    altmann Yvan Eht Nioj

    Registriert seit:
    23. November 2008
    Beiträge:
    1,176
    Danke:
    2,761
    Geschlecht:
    männlich
    Handy:
    derzeit: Wiko Highway Star
    Für Lollipop gibt es die CWM/TWRP scheinbar eh noch nicht. Will halt nur vom 4.4.4 System nen Backup machen, bevor ich Lollipop dann drüberbügel.
    Dort dürfte dann beim flashen die Custom Recovery eh wieder runterfliegen, oder sehe ich das falsch?

    Nur was bringt mir dann mein 4.4.4 Backup, wenn ich dann 5 drauf habe, aber die Custom Recoveries damit nicht laufen. Dann kann ich doch mein Backup eh nicht zurücklesen, da ich das Backup nicht in einem für SP-Flashtool geeigneten Format habe.

    Bin gerade ein wenig verwirrt..
     
  12. Ora
    Offline

    Ora Teste mit subjektiver Wahrnehmung

    Registriert seit:
    22. Februar 2013
    Beiträge:
    9,352
    Danke:
    6,383
    Handy:
    LeEco Le Max 2 (X820) <- Arbeitstier
    ELE Vowney Lite <- Kamerareferenz
    Leagoo Elite 1 <- Frau
    zenFone 2 <- Videokamera Monitor
    Für das P6000 stehen wohl für beide Android Versionen flashbare Stock ROM Versionen zur Verfügung. Damit solltest Du gefahrlos wechseln können.
    Auch hast Du für beide das preloader.bin.

    Deine Userdaten kannst Du auch mit dem SP Flashtool sichern, in dem Du nur diesen Bereich zurück liest.
    Diese Daten sind aber sowieso immer nur für die jeweilige Version nutzbar.
    Aufpassen solltest Du nur beim nvram. Und Dir Deine IMEI's gut sichern.
     
  13. borg2k
    Offline

    borg2k Member

    Registriert seit:
    16. März 2015
    Beiträge:
    64
    Danke:
    90
    Handy:
    THL 5000
    Den gleichen Fehler bekomme ich auch bei meinem THL 5000 beim Versuch eines Backups mit MTK Droid Tools und das Ding hat einen MT6592 drinnen.
     
  14. Ora
    Offline

    Ora Teste mit subjektiver Wahrnehmung

    Registriert seit:
    22. Februar 2013
    Beiträge:
    9,352
    Danke:
    6,383
    Handy:
    LeEco Le Max 2 (X820) <- Arbeitstier
    ELE Vowney Lite <- Kamerareferenz
    Leagoo Elite 1 <- Frau
    zenFone 2 <- Videokamera Monitor
    Hast Du ein SD Karte drin?
    Wenn nicht, lege mal eine ein und geteiltes ist es schon (grüner Status)?
     
  15. borg2k
    Offline

    borg2k Member

    Registriert seit:
    16. März 2015
    Beiträge:
    64
    Danke:
    90
    Handy:
    THL 5000
    SD ist drinnen und root in der shell hab ich auch (grünes Viereck in MTK DT)

    Mich stört das auch nicht weiter, denn ich hab Backups mit CWM-R angelegt. Das erste Backup vorm CWM-R flashen hab ich per SPFT als Readback erstellt, da hat MTK DT mir wenigstens die Adressen für liefern können und er hat das Rom File auch aufbereitet.

    Ich wollte damit nur sagen dass das Tool auch bei älteren SOC´s nicht 100% funktioniert. Bei einem Lenovo A7-40 Tablet widerrum geht das Backup 1a.
     
    Ora sagt Danke für diesen hilfreichen Beitrag.
  16. borg2k
    Offline

    borg2k Member

    Registriert seit:
    16. März 2015
    Beiträge:
    64
    Danke:
    90
    Handy:
    THL 5000
    Okay habs eben nochmal probiert, ist nicht ganz der gleiche Fehler, bei mir kommt der Fehler nicht bei nodl_proinfo sondern bei preloader_and_dsp. Ich kann aber normal per SPFT flashen, insofern muss der preloader intakt sein.

    siehe Screenshot

    MTK DT Fehler beim Backup.JPG
     
  17. altmann
    Offline

    altmann Yvan Eht Nioj

    Registriert seit:
    23. November 2008
    Beiträge:
    1,176
    Danke:
    2,761
    Geschlecht:
    männlich
    Handy:
    derzeit: Wiko Highway Star
    Danke für den Hinweis. Radios und IMEI habe ich mit dem Maui META 3G ausgelesen.
    Da hat der mir auch ne .INI-Datei erzeugt, in welcher meine IMEIs drin stehen. Sollte ich die nicht damit zurückgelesen bekommen, kriegt man die denke auch noch auf anderen Weg rein, oder? Wichtig ist doch erstmal nur, dass ich überhaupt weiss, wie sie lauten.
    Ist der Kram (IMEI, Radios, etc.) mein NVRam?
    Oder wie kann ich davon noch ein Backup machen?

    Bin hier auch ein wenig vorsichtig, da es ja das Gerät von meiner Frau ist. Wenn ich an meinen eigenen Telefonen rumbastel, isses net so schlimm, wenn mal was daneben geht. Dann wird halt 1-2 Tage gebastelt, dann läuft es wieder. Von meiner Gattin sehe ich da aber die rote Karte, wenn ihrers nicht läuft, hihi.

    Danke dir @Ora auf jedenfall schönmal für deine Hilfe. Bis jetzt habe ich noch keine wirklich ausführlichen Tutorials gefunden, bzw. wich immer irgendwas davon bei mir ab (Treiberinstallation, anderes Scatterfile, andere SP Flashversion, etc.). Das war bei meinen Samsung-Geräten immer einfacher, da gab es tonnenweise Tutorials.
    Aber hier muss man denke nur einmal das System dahinter verstehen, dann weiss man doch theoretisch bei allen MTK-Geräten wie es funktionieren müsste, oder? Mach mir da mal ein wenig Mut :grin:

    Edit: Ach, was mir noch kurz einfiel. im SP Flashtool, wenn ich das neue Rom eingeladen habe, was wähle ich da als Modus aus? "Download only", "Firmware Upgrade" oder "Format All+Download"? Geht um das Update von KitKat auf Lollipop..
    Hab jetzt alle drei verschiedenen Sachen in diversen Posts gelesen, deswegen die Frage an den Fachmann.
     
    Zuletzt bearbeitet: 28. Mai 2015
  18. Ora
    Offline

    Ora Teste mit subjektiver Wahrnehmung

    Registriert seit:
    22. Februar 2013
    Beiträge:
    9,352
    Danke:
    6,383
    Handy:
    LeEco Le Max 2 (X820) <- Arbeitstier
    ELE Vowney Lite <- Kamerareferenz
    Leagoo Elite 1 <- Frau
    zenFone 2 <- Videokamera Monitor
    Vergleiche mal die Scatterfiles.
    Ich nehme an, dass die Einprungadressen für die Sektionen abweichen. Insbesondere den nvram Bereich.
    Kannst ja vom 4.4 davon einen Read back sichern.
    Die präferierte Option beim Download ist Firmware Upgrade.
     
    altmann sagt Danke für diesen hilfreichen Beitrag.
  19. altmann
    Offline

    altmann Yvan Eht Nioj

    Registriert seit:
    23. November 2008
    Beiträge:
    1,176
    Danke:
    2,761
    Geschlecht:
    männlich
    Handy:
    derzeit: Wiko Highway Star
    Okay, testen kann ich erst heute Abend spät oder Morgen, Frau ist samt Telefon unterwegs :)

    Hab gerade aber mal das Scatterfile von KitKat und Lollipop mit WinMerge verglichen.
    Die Partition "nvram" hat bei beiden die gleichen Anfangsadressen. Abweichungen kommen interessanterweise erst recht spät, ab dem Index sys13 (custom), und dann zieht sich das natürlich durch.

    Viel kaputt machen kann man denke ich nicht. Solange man immer noch drauf kommt und der Bootloader nicht komplett weg ist, sollte man denke ich immer flashen können. Habs zumindest noch nie geschafft, irgendnen Device zu bricken :grin:

    Kann ich durch die Scatterfiles eigentlich mein eigenes Layout (System- / Datenpartition) umsetzen, wenns mal wieder so eine blöde 2/14GB Aufteilung gibt, oder ist das eine gaaaaanz schlechte Idee?
     
  20. Ora
    Offline

    Ora Teste mit subjektiver Wahrnehmung

    Registriert seit:
    22. Februar 2013
    Beiträge:
    9,352
    Danke:
    6,383
    Handy:
    LeEco Le Max 2 (X820) <- Arbeitstier
    ELE Vowney Lite <- Kamerareferenz
    Leagoo Elite 1 <- Frau
    zenFone 2 <- Videokamera Monitor
    Man könnte, aber ist nicht nur mit einem anderen Scatter zu machen!
    Schaue mal in meine Signatur:)