1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Star N9500 - kein GPS und kein Kompass

Dieses Thema im Forum "Allgemeine Informationen/Fragen" wurde erstellt von homelike, 22. April 2013.

  1. Stevenious
    Offline

    Stevenious Member

    Registriert seit:
    13. Januar 2010
    Beiträge:
    155
    Danke:
    2
    Handy:
    w200i
    lg kp100
    i9b 3gs
    C6a
    neu dazu gekommen
    Q4
    AW: Star N9500 - kein GPS und kein Kompass

    Hey bei mir hat sich auch nicht merklich was am Empfang oder snr geändert. Morgen mal bei Sonnenwetter probieren..
    Aber 1. Fix war da..danach keinen 2. Fix an anderem Ort erreicht..geduldsspiel...
    Gesendet von meinem Samsung Galaxy 4 mit Tapatalk 2
     
  2. Amboss67
    Offline

    Amboss67 New Member

    Registriert seit:
    17. Mai 2013
    Beiträge:
    96
    Danke:
    7
    Handy:
    i9500 (S4-Klon, Alps)
    Hat denn schon einmal jemand ein N9500 disassembled?

    Wo liegt die Antenne? Ist das eine kleine Folie oder eine Leiterbahn?
    Als alter CB-Funker weiß ich dass kleine Fehler in der Auslegung einer Antenne eine große (negative) Wirkung haben können.

    Oder ist am Ende gar doch noch ein Software-Fix möglich, z.B. in der Form, dass man etwa die GPS-Empfindlichkeit programmieren kann, so wie beispielsweise die Hörerlautstärke bei manchen Geräten?

    Ich bin nämlich von dem Handy mehr als begeistert. Alles funktioniert toll, auch das WLan. Die Kamera ist auch hervorragend.
    Aber ich möchte eben auch damit navigieren können... und so wie es jetzt ist, kann man das abhaken.

    Die Navigation ist nicht nur schlecht, sondern völlig unmöglich.

    Gruß Amboss
     
    Zuletzt bearbeitet: 20. Mai 2013
  3. Ora
    Offline

    Ora Teste mit subjektiver Wahrnehmung

    Registriert seit:
    22. Februar 2013
    Beiträge:
    9,347
    Danke:
    6,374
    Handy:
    LeEco Le Max 2 (X820) <- Arbeitstier
    ELE Vowney Lite <- Kamerareferenz
    Leagoo Elite 1 <- Frau
    zenFone 2 <- Videokamera Monitor
    AW: Star N9500 - kein GPS und kein Kompass

    Gibt es unter /etc ein gps Verzeichnis?
    Wenn ja, liegt da eine xml File?
     
  4. Amboss67
    Offline

    Amboss67 New Member

    Registriert seit:
    17. Mai 2013
    Beiträge:
    96
    Danke:
    7
    Handy:
    i9500 (S4-Klon, Alps)
    Ich habe unter /etc kein gps Verzeichnis.
     
  5. Stevenious
    Offline

    Stevenious Member

    Registriert seit:
    13. Januar 2010
    Beiträge:
    155
    Danke:
    2
    Handy:
    w200i
    lg kp100
    i9b 3gs
    C6a
    neu dazu gekommen
    Q4
    Hey
    Also im /etc Verzeichnis sind nur
    Agps_profiles_conf XML
    Epo_conf.xml
    GPS.conf
    Was mit GPS Zutun haben könnte ;)
    Also oben links auf der Rückseite steht auf ner weißen Folie / Leiterbahn
    GPS/ wifi/Bt


    Gesendet von meinem iPad mit Tapatalk HD
     
  6. Amboss67
    Offline

    Amboss67 New Member

    Registriert seit:
    17. Mai 2013
    Beiträge:
    96
    Danke:
    7
    Handy:
    i9500 (S4-Klon, Alps)
    Bei mir ist die Folie schwarz. Habe sie an der linken Seite angelöst und irgendwann ist auf der Rückseite eine aufgedruckte Kupferleitbahn zu sehen.
    Die Folie ist also eine Antenne (bzw.mehrere). Habe die Folie wieder festgedrückt, denn wenn man sie nun abzieht, dürfte die "Klebeantenne" im Eimer sein.

    Nun habe ich mir mehrere Stücke Alufolie geschnitten und zweimal gefaltet (also vier Lagen dick).
    Verschiedene Formen vom Quadrat über einen Streifen bis zu verschiedenen L-Formen habe ich bei abgenommenem Deckel auf die Folienantenne gedrückt und hin- und her geschoben. Gleichzeitig stand ich im freien und habe mir mit GPS Test die Signalstärken angeschaut.

    Und es tut sich tatsächlich etwas.

    Die größte Wirkung hat ein ein Streifen von ungefähr 8mm Breite, den man quer ganz oben (also über das Objektiv hinweg) hält.
    Es kommt auf die Länge an und auch darauf wie er genau liegt.

    Zwischendurch hatte ich sogar einmal ein dermaßen starkes Signal auf mehreren Satelliten, dass ich gedacht habe "DAS ISSES".

    Also habe ich den Alu-Streifen an dieser Stelle mit Tesa fixiert und den Deckel aufgesetzt. Dann war das Signal wieder schwächer.

    Ich hab dann begriffen, dass es einen unterschied macht, wenn man den Streifen beim Testen mit den Fingern berührt oder mit einem nichtleitenden Gegenstand andrückt.

    Also weiter probiert. Irgendwann hatte ich tatsächlich einen Streifen, der bei geschlossenem Deckel funktioniert hat.
    Bei GPS Test hatte ich plötzlich gleich mehrere Sats im mittleren 30er Bereich...
    Die Navigation funktionierte direkt mindestens eine Note besser. Im Auto hatte ich weniger Signalverlust als vorher. Und nach einem Signalverlust werden die Sats erheblich schneller neu gefixt. Das Ganze war aber immer noch nicht wirklich gut.
    Also hab ich mir gedacht, das geht noch besser. Streifen wieder entfernt und die letzten drei Stunden habe ich wieder mit Alufolie herum gespielt.
    Leider hab ich kein besseres Ergebnis mehr erreichen können.

    Schlimmer noch, ich krieg es nicht mehr so gut hin wie vorher. Es kommt ganz wesentlich auf die Länge des Alu-Streifens an und auch auf dessen genaue Position. 1mm daneben und nix geht mehr.


    Mit einem überlangen Streifen, der an beiden Seiten des Geräts ca. 3-4cm herausschaut und der gleichzeitig hinten rechts oben mit einem Finger angedrückt wird, erhalte ich sogar ein Bombensignal, das eigentlich aussieht wie auf unserem S2. Ab und zu springt auch immer mal wieder ein Satellit auf Stärke 40.
    ... aber alles, was irgendwie ins Gerät passt, bringt nicht die gewünschte Performance.

    Wenn der Streifen quer verlegt wird, bringt es was. Sobald man die Folie von oben nach unten führt, bringt sie gar nichts mehr.
    So weit bin ich schonmal.

    Ich hab im Moment keine Geduld mehr, werde es aber demnächst sicher noch einmal angehen.

    Unterm Strich kann man sagen, dass höchstwahrscheinlich einfach nur das Antennendesign schlecht ist. Dort könnte der Hund begraben liegen. Die Chinesen haben sicherlich noch nie etwas von Stehwelle gehört.
     
    Zuletzt bearbeitet: 21. Mai 2013
  7. lauterohre
    Offline

    lauterohre Skynet is online

    Registriert seit:
    10. August 2012
    Beiträge:
    393
    Danke:
    725
    Handy:
    Atom Z2580
    Hallo Amboss67,
    sehr interessanter Beitrag und spiegelt meine Erfahrungen exact wieder.
    Wenn auch mit einem anderen Handy (U920).
    Nach mehreren Tests mit Alufolie oder einem dünnen Draht
    habe ich festgestellt das, wenn eine solche Konstruktion im
    Handy eingebaut ist, das Signal wieder schlecht ist.
    Ich habe das Problem für mich akzeptabel gelöst indem ich
    den im Handy eingesteckten "Stylus" entfernt und an desse
    Stelle eine Teleskopantenne eingeklebt und mit einem Draht
    am GPS-Anschluss auf der Platine verlötet habe.
    Jetz habe ich im Auto eine Genauigkeit von unter 10m.
    Sygic funktioniert damit einwandfrei.
    Natürlich sollte man zuerst die Softwareanpassung machen
    wie oft im Forum beschrieben. Bei den meisten Geräten
    funktioniert es dann ja einwandfrei.
    Gruß
     
  8. pontari
    Offline

    pontari Member

    Registriert seit:
    30. März 2013
    Beiträge:
    100
    Danke:
    3
    Handy:
    Hero 7500+
    AW: Star N9500 - kein GPS und kein Kompass

    Hallo,

    Könntest Du vielleicht mal ein Bild von deiner Konstruktion machen :) bei meinem H7500+ sieht es so aus das die Antenne zweigeteilt ist. Wlan und gps. Wenn man die Fläche für GPS z.B. durch ein Stück Kupfer Folie vergrößert ? Könnte das was bringen? Weil mehr wie dünne Leiterbahnen scheint die Antenne nicht zu sein.

    Gruß
     
  9. Amboss67
    Offline

    Amboss67 New Member

    Registriert seit:
    17. Mai 2013
    Beiträge:
    96
    Danke:
    7
    Handy:
    i9500 (S4-Klon, Alps)
    Die Softwareanpassungen hab ich auch gemacht. Auch noch die aus anderen Foren. Lediglich eine gpsconfig.xml kann ich nirgens finden, um sie zu ersetzen. Aber vielleicht existiert die bei 4.2.1 gar nicht?! Oder weiß Jemand, in welchem Verzeichnis die zu finden ist? Aber evtl. sind auch noch andere Fixes notwendig, die noch nicht bekannt sind?
    Der Software Fix hat auch ganz gut funktioniert. Sofort beim starten, weiß GPS Test wieviele Sats gerade "in View" sind.
    Diese Software-Fixes sind aber nur ein Teil der Lösung, denn sie beziehen sich ja eigentlich bisher immer nur auf die Fähigkeit ohne Datenverbindung schneller zu fixen. Anschließend geht der Fix ja auch recht flott.
    Aber mein viel größeres Problem ist, dass die Hardware danach immer noch nicht in der Lage ist, diese Sats stark genug zu empfangen und vor allen Dingen das Signal zu halten. Das Signal wird zu oft verloren bzw. es gibt Empfangsfehler, weshalb dann die Navi-Software anfängt zu spinnen.
    Übrigens hab ich mit dem Streifen hinten dran (bei offenem Deckel) teilweise sogar eine Genauigkeit von 3-4m laut GPS Test.



    Bei meinem N9500 kann man die Kupferleiterbahnen der Antenne durch die Folie hindurch schimmern sehen. Es scheint nur einen einzigen Anschluß zu geben, der von der Platine kommt. (Bin mir nicht ganz sicher aber es scheint so zu sein. Um es 100% zu klären, müsste man das Gerät auseinander nehmen).
    Später teilt sich dann die Antenne (quasi wie ein Y-Abzeig). Beide Bahnen haben dann verschiedene Längen, vermutlich um den verschiedenen Frequenzen von Wi-Fi und GPS gerecht zu werden.




    Nun ist mir noch etwas anderes aufgefallen. Ein Freund von mir hat ein N-7100. Dieser Note-Klon mit Dual-Core und 512MB, der sich mit der Bezeichnung 7102 unter AnTuTu meldet , von efox.
    Als wir vorgestern Abend zusammen am Lagerfeuer saßen hab ich ihm GPS Test runter geladen und dann haben wir unter freiem Himmel mal unsere Ergebnisse verglichen. Das waren dann mit dem S2 drei Geräte nebeneinander.

    GPS Test macht folgende komische Sache auf dem Samsung S2 und auf meinem N9500: Wenn man das Gerät um 90 Grad dreht und das Display auf quer schaltet, verliert GPS Test jedesmal sein Signal. Das gleiche beim Umschalten auf Vertikal. Es dauert dann ein paar Sekunden bis GPS Test wieder Sats fixt. Beim S2 geht das erheblich schneller als auf meinem N9500.

    Aber dieses N7100 von meinem Kumpel verhält sich völlig anders. Zum einen hat es ein stärkeres Signal als mein 9500 (liegt irgendwo zwischen dem S2 und meinem 9500). Aber das Interessanteste beim 7100 ist: Wenn man das Gerät dreht und das Display umschaltet, verliert GPS Test auf diesem Gerät NICHT das Signal, sondern macht unbeeindruckt weiter. Wir haben das mehrmals probiert... immer hält das 7100 das Signal.

    Das könnte bedeuten, dass es evtl. noch weitere Software-Fixes gibt, die dazu führen, dass das Sat-Signal besser gehalten wird bzw. durch andere Prozesse nicht so leicht unterbrochen wird?! Wobei dann natürlich auch wieder die Tatsache dagegen steht, dass das S2 beim GPS test ebenfalls kurz unterbricht aber bei einer realen Navigation dennoch richtig stark funktioniert und sein Signal quasi nie verliert. Dennoch könnte es natürlich sein, dass wegen irgendwelcher Software-Bugs bei uns die Navigation gestört wird.

    Vielleicht könnt Ihr das mal mit euren Geräten testen? ... würde mich interessieren, wie das bei euch ist. Einfach das Gerät um 90 Grad drehen, wenn GPS Test bereits gefixt hat und schauen, ob dann das Signal verloren geht.
     
    Zuletzt bearbeitet: 22. Mai 2013
  10. lauterohre
    Offline

    lauterohre Skynet is online

    Registriert seit:
    10. August 2012
    Beiträge:
    393
    Danke:
    725
    Handy:
    Atom Z2580
    Nein, kein Signalverlust bei meinem U920 (MTK6577).
    Und hier für alle die sich mal totlachen wollen meine GPS-Antenne. Fotografiert auf dem Schreibtisch unter dem Dachfenster.
    U920_GPS-Antenne.jpg
     
    Zuletzt bearbeitet: 22. Mai 2013
  11. Ora
    Offline

    Ora Teste mit subjektiver Wahrnehmung

    Registriert seit:
    22. Februar 2013
    Beiträge:
    9,347
    Danke:
    6,374
    Handy:
    LeEco Le Max 2 (X820) <- Arbeitstier
    ELE Vowney Lite <- Kamerareferenz
    Leagoo Elite 1 <- Frau
    zenFone 2 <- Videokamera Monitor
    AW: Star N9500 - kein GPS und kein Kompass

    1. Keines der von mir getesteten Chinaphones nutzen eine /etc/gps/gpsconfig.XML
    2. Die drei Hilfsdateien von mir verbessern lediglich das "Fixen", also eine schnellere Ortsbestimmung, nicht aber die Empfangsfeldstärke. Da gilt es vorher Erfahrungen anderer Besitzer von Chinesischen Geräten zu erfragen. Und schon sind wir bei den kleinen Unterschieden.
    Wir Ihr ja mitbekommen habt, gibt es riesige Unterschiede. Mit meinem Cubot M6584 habe ich null Probleme. Auch das "Drehphänomen" kann ich nicht beobachten.
    Vor Drehung
    [​IMG]
    Nach Drehung
    [​IMG]
     
  12. pontari
    Offline

    pontari Member

    Registriert seit:
    30. März 2013
    Beiträge:
    100
    Danke:
    3
    Handy:
    Hero 7500+
    AW: Star N9500 - kein GPS und kein Kompass

    lauterohre: na das ist ja mal geil :thumbup: mein erstes Handy hatte auch so eine Antenne hahaha
    Mit dem Teil müsste dein Smartphone aber vollausschlag haben :)
     
  13. Stevenious
    Offline

    Stevenious Member

    Registriert seit:
    13. Januar 2010
    Beiträge:
    155
    Danke:
    2
    Handy:
    w200i
    lg kp100
    i9b 3gs
    C6a
    neu dazu gekommen
    Q4
    AW: Star N9500 - kein GPS und kein Kompass

    Hey bei meinem N9500 ist das selbe prob bei Drehung..ka wo der Fehler da ist... aber hab nicht mehr als 20% Snr wert..
    So mal die Idee Mit der Alufolie aufgegriffen nun bekommen ich wenigstens Nen fix im Haus und nach 20 sek. ..
    [​IMG]
    [​IMG]
    Gesendet von meinem Samsung Galaxy 4 mit Tapatalk 2
     
    Zuletzt bearbeitet: 22. Mai 2013
  14. Daemonarch
    Offline

    Daemonarch Chiclone-Lover

    Registriert seit:
    20. Dezember 2011
    Beiträge:
    2,386
    Danke:
    711
    Geschlecht:
    männlich
    Handy:
    No.1-N3, Doogee DG2014, Samsung Galaxy S1+, S2, Note1, Note2...
    Na, dann kannste ja jetzt wenigstens im Haus navigieren... :thumb_up:
     
  15. Ora
    Offline

    Ora Teste mit subjektiver Wahrnehmung

    Registriert seit:
    22. Februar 2013
    Beiträge:
    9,347
    Danke:
    6,374
    Handy:
    LeEco Le Max 2 (X820) <- Arbeitstier
    ELE Vowney Lite <- Kamerareferenz
    Leagoo Elite 1 <- Frau
    zenFone 2 <- Videokamera Monitor
    AW: Star N9500 - kein GPS und kein Kompass

    Aber wie man einen SS macht, muss er noch lernen... Power & Lautstärke leiser gleichzeitig für 1 s drücken:)
     
  16. Stevenious
    Offline

    Stevenious Member

    Registriert seit:
    13. Januar 2010
    Beiträge:
    155
    Danke:
    2
    Handy:
    w200i
    lg kp100
    i9b 3gs
    C6a
    neu dazu gekommen
    Q4
    AW: Star N9500 - kein GPS und kein Kompass

    Ah wieder wat gelernt..danke..

    Gesendet von meinem Samsung Galaxy 4 mit Tapatalk 2
     
  17. Amboss67
    Offline

    Amboss67 New Member

    Registriert seit:
    17. Mai 2013
    Beiträge:
    96
    Danke:
    7
    Handy:
    i9500 (S4-Klon, Alps)
    Hier könnt Ihr mal einen Vergleich sehen.

    Star I9500 gegen Galaxy Mini (2 jahre alt) bei uns auf dem Terrassentisch:

    Wie Ihr im Hintergrund hören könnt, hat es heute Morgen recht stark geregnet, der Himmel war also wolkenverhangen, was den Empfang nochmal zusätzlich beeinträchtigt.
    Das Star ist wieder im Ur-Zustand, denn ich habe den Verkäufer bereits kontaktiert, dass ich es zurück schicken möchte.

    Achtet mal darauf, wie das Star seine läpschen drei Satelliten verliert, nur weil ich mich mit der Kamera nähere :to_take_umbrage:

    http://www.youtube.com/watch?v=fYmcGmzs04E&feature=youtu.be

    (Wenn die Quali schlecht ist, bei youtube auf 720p umstellen)


    Gruß Amboss
     
    Zuletzt bearbeitet: 23. Mai 2013
  18. Hackbarth
    Offline

    Hackbarth Member

    Registriert seit:
    11. September 2009
    Beiträge:
    168
    Danke:
    2
    Handy:
    XDA Diamond
    Hallo
    Also ich denke mittlerweile auch es liegt am Empfänger der zu schwach ausgelegt ist.. Aber ich habe auch was beobachtet:
    Das Backcover ohne Flip Display Deckel ist in Metallick lackiert.
    Met. Lackierungen beinhalten in der tat metal späne.
    Bei den ersten Audi A8 war der GPS Empfänger auf der Heckklappe montiert und nicht in Metallick lackiert auch wenn das Auto ( hatten sie alle ) met. war. Grund waren Empfangsprobleme.
    Vergleicht man nun den Deckel mit dem zweiten (der mit dem Displaydeckel) stellt man fest der ist nicht in met. Lackiert.
    Beim direkten vergleich ist der Empfang ohne Deckel klar am besten, gefolgt vom Deckel mit Flip Cover und dann ganz schlecht der Deckel ohne Flip Cover...
    Die Kombination von schwachen Empf. und Met. Deckel erzeugen unser problem.
    Die ganze cfg. geschichten verbessern nur den ersten Fix, der Empfang bleibt schlecht und bricht gerne mal ab.
    Ich nutze im Auto nun ein BT. GPS Empfänger den ich noch liegen hatte.
    Probiert das mal aus und berichtet.

    Hackbarth
     
  19. Amboss67
    Offline

    Amboss67 New Member

    Registriert seit:
    17. Mai 2013
    Beiträge:
    96
    Danke:
    7
    Handy:
    i9500 (S4-Klon, Alps)
    Ich hab das GPS Problem durch Verkauf gelöst. Ein guter Bekannter möchte es haben.... GPS interessiert ihn nicht die Bohne.
    Der Shop hat mir einen Gutschein angeboten (30EUR) wenn ich das Handy trotz des Fehlers behalte.

    Schade drum, denn alles andere hat mir am 9500 richtig gut gefallen.


    Nun werd ich mal recherchieren, welcher China-Böller mit Quad-Core und 4,5 bis max. 5 Zoll denn in Sachen GPS am besten unterwegs ist.


    Gruß Amboss
     
  20. Stevenious
    Offline

    Stevenious Member

    Registriert seit:
    13. Januar 2010
    Beiträge:
    155
    Danke:
    2
    Handy:
    w200i
    lg kp100
    i9b 3gs
    C6a
    neu dazu gekommen
    Q4
    Also wie schon berichtet hab ich es mit dem alufolientrick probiert.
    Habe sie dann erst oben wie ne Antenne raushängen lassen und dann getestet, ob man sie auch im Bäckchen verschwinden lassen kann und siehe da man bekam trotzdem nen fix.. Heute dann getestet auf 100km erst wollte es nicht so recht aber bei dem richtigen Neigungswinkel oder so fünfte es auf einmal wunderbar als Navigation im Auto..am Anfang kam immer GPS gesucht Balken kamen und waren wieder weg das ganze ging dann eben solange bis ich eben den Neigungswinkel der Halterung etwas Raumprobleme hatte..dazu eben die alufolientrick im backcover und schon fünfte das GPS auf ca. 4-6m genau also nicht wie sonst das man auf der falschenspur fuhr ...testet es einfach mal erst im freien zum fixen wenn ihr nen Navigation braucht.


    Gesendet von meinem N9500 mit Tapatalk