1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Teclast X16 Pro bricked durch dummes flashen :(

Dieses Thema im Forum "Allgemeine Informationen/Fragen" wurde erstellt von Binser, 8. Februar 2016.

  1. Binser
    Offline

    Binser Well-Known Member

    Registriert seit:
    23. Mai 2013
    Beiträge:
    318
    Danke:
    287
    Handy:
    Xiaomi Mi Max, K3 Note, Alife S1, LG P500, Sony Xperia X8, Teclast X16 Pro, Nook ST, Fire TV, MK809 Plus, MK808B Plus
    Bei meinen Versuchen Xposed zu installieren, habe ich eine kleine Dummheit gemacht: Ich hatte Flashify, Rashr und Flashfire getestet und versucht ein Backup meines Recovery zu machen.

    Leider waren diese Backups dann nirgendwo auf meinem Gerät sichtbar. Ich erhielt allerdings auch nie eine Fehlermeldung.

    Flashify zeigte mir an, daß ein Backup gemacht wurde, aber ich konnte er nirgends finden.

    Dann dachte ich, versuche mal den Restore Befehl bei Flashify vom Backup des angezeigten Recovery, vielleicht zeigt Dir die App dann ja den Pfad an, wo dieser Backup sein könnte.

    Also klick ich auf restore und ohne irgendwelchen Bestätigungsdialog macht die App anscheinend einen Flash dieses eventuell leeren Recoverys.

    Resultat: Wenn ich jetzt Android boote, erhalte ich den bekannten zur Reparatur auf den Rücken liegenden Androiden mit geöffneter Klappe.

    Bevor ich daran ging den Teclast X 16 Pro einzurichten, habe ich erstmal ein Image sämtlicher Partitionen (inkl. RAW und Ext4 - insgesamt 16 Partitionen) mit Drive Snapshot gemacht. Das Backup liegt also als quasi letzter Rettungsschirm vor.

    Aber erst einmal wollte ich fragen, ob vielleicht jemand von Euch weiß, wie ich wieder Android booten kann ohne daß ich mein Image benutze?

    Danke. :)
     
  2. tommy0815
    Offline

    tommy0815 Well-Known Member

    Registriert seit:
    26. November 2010
    Beiträge:
    3,896
    Danke:
    808
    Handy:
    Samsung Galaxy Note 4
    Oppo Find 7
    @Binser
    wenn du doch ein komplettes backup hast, dann befindet sich doch auch ein Recovery darin?
    Dann würde ich erst mal nur das Recovery (erneut) flashen. Dann sollte es mit Glück wieder laufen, evtl ist aber noch ein wipe nötig.
     
    Binser sagt Danke für diesen hilfreichen Beitrag.
  3. N2k1
    Offline

    N2k1 Well-Known Member

    Registriert seit:
    8. Juni 2010
    Beiträge:
    4,122
    Danke:
    938
    Handy:
    Elephone P7000
    Elephone P8
    Genau das bootet er ja gerade. Ist also genau das, was er nicht braucht.
    @Binser Hast DU irgendwo ein Boot-Image gesichert? Wenn ja, dann einfach per fastboot flash boot boot.img im Fastboot-Modus in das Gerät bringen. Fertig.
    Es sei denn, Deine Vol+ Taste hängt, dann ist klar, daß er ins Recovery bootet.
     
    Binser sagt Danke für diesen hilfreichen Beitrag.
  4. Binser
    Offline

    Binser Well-Known Member

    Registriert seit:
    23. Mai 2013
    Beiträge:
    318
    Danke:
    287
    Handy:
    Xiaomi Mi Max, K3 Note, Alife S1, LG P500, Sony Xperia X8, Teclast X16 Pro, Nook ST, Fire TV, MK809 Plus, MK808B Plus
    Danke für Eure Antworten.

    In Ermangelung eines Recoverys für das Teclast, habe ich leider kein Boot.img, sondern bin dann auf das Imaging mit Drive Snapshot innerhalb des Windows 10 ausgewichen.

    Hier befinden sich Details dazu.

    Ich spekuliere, das eine dieser Partitionssicherungen (wie gekennzeichnet) die Boot Partition wäre, und eine andere das Stock Recovery.

    Ich bin mir da aber nicht 100%ig sicher.

    Ich habe jetzt ein weiteres Image gemacht, und was mich ein bißchen irritiert, ist, dass alle Partitionen, auch die RAW Partitionen, jetzt z.T. leichte, z.T. erhebliche Veränderungen aufweisen. Das macht mich etwas unsicher, denn ansonsten hatte ich eben auch die Idee Boot und Recovery Partitionen durch das Image im eingebauten Windows 10 widerherzustellen.
     
  5. Binser
    Offline

    Binser Well-Known Member

    Registriert seit:
    23. Mai 2013
    Beiträge:
    318
    Danke:
    287
    Handy:
    Xiaomi Mi Max, K3 Note, Alife S1, LG P500, Sony Xperia X8, Teclast X16 Pro, Nook ST, Fire TV, MK809 Plus, MK808B Plus
    Ich habe jetzt die HD1-11 (Boot nehme ich an) wiederhergestellt und dann neu gebootet mit dem selben Resultat.

    Dann die HD1-12 (Recovery nehme ich an) und auch keine Besserung.

    Mir fällt jetzt nichts mehr ein (ausser vielleicht einer sehr aufwändigen Vollwiederherstellung).

    P. S. : Mir kam noch gerade in den Sinn, dass ich kurz vor dem Problem den Bootloader entsperrt habe...
     
    Zuletzt bearbeitet: 9. Februar 2016
  6. N2k1
    Offline

    N2k1 Well-Known Member

    Registriert seit:
    8. Juni 2010
    Beiträge:
    4,122
    Danke:
    938
    Handy:
    Elephone P7000
    Elephone P8
    Welches welche Partition ist, kannst Du doch recht schnell mit einem beliebigen Programm, welches Dir erlaubt die Daten als Hex anzusehen, kontrollieren.
     
  7. Binser
    Offline

    Binser Well-Known Member

    Registriert seit:
    23. Mai 2013
    Beiträge:
    318
    Danke:
    287
    Handy:
    Xiaomi Mi Max, K3 Note, Alife S1, LG P500, Sony Xperia X8, Teclast X16 Pro, Nook ST, Fire TV, MK809 Plus, MK808B Plus
    Genau so habe ich es auch gemacht. Dennoch kann es sein, daß ich daneben liege.
     
  8. Binser
    Offline

    Binser Well-Known Member

    Registriert seit:
    23. Mai 2013
    Beiträge:
    318
    Danke:
    287
    Handy:
    Xiaomi Mi Max, K3 Note, Alife S1, LG P500, Sony Xperia X8, Teclast X16 Pro, Nook ST, Fire TV, MK809 Plus, MK808B Plus
    OK, es gab jetzt ein wenig Fortschritt.
    Ich habe jetzt mal mit Testdisk die Partitionen untersucht, und siehe da, was hat Testdisk mir angezeigt?

    Eigentlich alles was man wissen müßte:

    TESTDISK
    Disk /dev/sda - 62 GB / 58 GiB - CHS 7603 255 63
    Current partition structure:
    Partition Start End Size in sectors
    1 P Unknown 2048 206847 204800 [android_bootloader2]
    2 P EFI System 206848 411647 204800 [android_bootloader]
    3 P Unknown 411648 473087 61440 [android_boot]
    4 P Unknown 473088 534527 61440 [android_recovery]
    5 P Unknown 534528 536575 2048 [android_misc]
    6 P Unknown 536576 569343 32768 [android_metadata]
    7 P Unknown 569344 8433663 7864320 [android_system]
    8 P Unknown 8433664 8957951 524288 [android_cache]
    9 P Unknown 8957952 50900991 41943040 [android_data]
    10 P Unknown 50900992 50903039 2048 [android_persistent]
    11 P Unknown 50903040 50919423 16384 [android_config]
    12 P Unknown 50919424 50939903 20480 [android_factory]
    13 P EFI System 50939904 51202047 262144 [EFI system partition]
    No FAT, NTFS, ext2, JFS, Reiser, cramfs or XFS marker
    14 P MS Reserved 51202048 51234815 32768 [Microsoft reserved partition]
    14 P MS Reserved 51202048 51234815 32768 [Microsoft reserved partition]
    15 P MS Data 51234816 121116671 69881856 [Basic data partition]
    16 P Unknown 121116672 122140671 1024000 [Basic data partition]

    Hier mal zum Vergleich meine spekulierten Werte (aus diesem Thread):

    GPT Disk 64 GB on Teclast X16 Pro - Partition Breakdown
    HD1-1.sna RAW Size: 100MB
    HD1-2.sna Boot EFI Partition (FAT), Label: ANDROIDIA, Size: 100MB
    HD1-3.sna RAW, Size: 30MB
    HD1-4.sna RAW, Size: 30MB
    HD1-5.sna RAW, Size: 1MB
    HD1-6.sna RAW, Size: 16MB
    Hd1-7 Virgin Android Ext4 Partition Teclast X 16 Pro.SNA, Size: 3840MB probably Android system files (since it is smaller than HD1-9 which should be data and user apps)
    HD1-8.sna Ext4, Size: 256 MB, 35 MB used - probably cache after examining raw HEX
    HD1-9 Virgin Android Ext4 Partition Teclast X 16 Pro.SNA, Size: 20480MB (probably data and user apps, since this is the biggest Android partition)
    HD1-10.sna RAW, Size: 1MB
    HD1-11.sna Ext4, Size: 8 MB, 4 MB used - probably boot after examining raw HEX
    HD1-12.sna Ext4, Size: 10 MB, 4 MB used - probably recovery after examining raw HEX
    HD1-13 SYSTEM FAT 32.sna, Size: 128MB Label: SYSTEM, EFI vsystem Microsoft
    HD1-14.sna RAW, Size: 16MB
    HD1-15 Virgin Win10 C Partition Teclast X 16 Pro.SNA, Size: 34122MB, Windows 10 Main C Drive NTFS
    HD1-16 Recovery NTFS.sna, Size: 500MB Label: Recovery

    Also lag ich wohl ganz schön daneben. Aber ich bin froh, daß ich den Testdisk Weg gefunden habe, und hoffe, dies könnte anderen auch helfen.

    Ich werde jetzt also erst einmal Partition 3 von meinem Image wiederherstellen und dann weiter berichten.
     
    tommy0815 sagt Danke für diesen hilfreichen Beitrag.
  9. Binser
    Offline

    Binser Well-Known Member

    Registriert seit:
    23. Mai 2013
    Beiträge:
    318
    Danke:
    287
    Handy:
    Xiaomi Mi Max, K3 Note, Alife S1, LG P500, Sony Xperia X8, Teclast X16 Pro, Nook ST, Fire TV, MK809 Plus, MK808B Plus
    SUCCESS!!!!

    Das Wiederherstellen der Boot Partition (HD1-3) hat es mir erlaubt, Android wieder zu booten! :)
     
    Skyfire, tommy0815, N2k1 und eine weitere Person sagen Danke für diesen hilfreichen Beitrag.
  10. dorschdns
    Offline

    dorschdns ClonePhone Facharzt

    Registriert seit:
    15. Oktober 2009
    Beiträge:
    2,052
    Danke:
    1,677
    Geschlecht:
    männlich
    Handy:
    Oukitel U10
    Cubot X9
    INEW V3
    Doogee Turbo2014
    GT-I9500 1micro Sim
    H868
    I5C
    Super !!!!!!
    Gratulation!!!!!:feuerwerk::feuerwerk::feuerwerk:
     
    Binser sagt Danke für diesen hilfreichen Beitrag.
  11. Binser
    Offline

    Binser Well-Known Member

    Registriert seit:
    23. Mai 2013
    Beiträge:
    318
    Danke:
    287
    Handy:
    Xiaomi Mi Max, K3 Note, Alife S1, LG P500, Sony Xperia X8, Teclast X16 Pro, Nook ST, Fire TV, MK809 Plus, MK808B Plus
    Noch in Addendum zu dieser Aktion:

    Mein Firefox Browser crashte sofort beim Start, sogar nach einer Neuinstallation.
    Also dachte ich, es könnte vielleicht mit den Partitionen 11 & 12 zu tun haben, die ich irrtümlicherweise (s.o.) wiederhergestellt habe.

    Ich hatte vor der Reparatur noch ein Image des Status Quo gemacht, und konnte deshalb die Partition 11 zurückspiegeln, wie sie zur Zeit des gebrickten Tablets war.

    Und siehe da, der Firefox läuft jetzt wieder.

    Kann mir jemand genaueres über den Zweck der Partitionen
    11 P Unknown 50903040 50919423 16384 [android_config]
    12 P Unknown 50919424 50939903 20480 [android_factory]
    erzählen?

    Ich denke, vielleicht sollte ich auch die Partition 12 (factory) wieder zurückspiegeln.
     
  12. N2k1
    Offline

    N2k1 Well-Known Member

    Registriert seit:
    8. Juni 2010
    Beiträge:
    4,122
    Danke:
    938
    Handy:
    Elephone P7000
    Elephone P8
    Mein Beitrag war auch auf diesen hier bezogen - da habe ich wohl nur den falschen Thread erwischt.
     
  13. Binser
    Offline

    Binser Well-Known Member

    Registriert seit:
    23. Mai 2013
    Beiträge:
    318
    Danke:
    287
    Handy:
    Xiaomi Mi Max, K3 Note, Alife S1, LG P500, Sony Xperia X8, Teclast X16 Pro, Nook ST, Fire TV, MK809 Plus, MK808B Plus
    OK, das macht jetzt mehr Sinn. Aber was ich vielleicht nicht genug erklärt habe, ist das ich nicht wie bei Android üblich das Backup mit einem Recovery gemacht habe, sondern mit Drive Snapshot innerhalb Windows 10 (auf dem gleichen Dual Boot Tablet) und ich deswegen eine solche Partition leider nicht ohne weiteres mounten kann.

    Aber ich werde noch mal mit Testdisk versuchen, den Inhalt des Dateisystems des Tablets zu lesen.

    Ich hatte nur gehofft, daß hier jemand weiß was es mit diesen beiden Partitionen auf sich hat.
     
  14. N2k1
    Offline

    N2k1 Well-Known Member

    Registriert seit:
    8. Juni 2010
    Beiträge:
    4,122
    Danke:
    938
    Handy:
    Elephone P7000
    Elephone P8
  15. Binser
    Offline

    Binser Well-Known Member

    Registriert seit:
    23. Mai 2013
    Beiträge:
    318
    Danke:
    287
    Handy:
    Xiaomi Mi Max, K3 Note, Alife S1, LG P500, Sony Xperia X8, Teclast X16 Pro, Nook ST, Fire TV, MK809 Plus, MK808B Plus
    Ich weiß - ich sagte ja "nicht ohne weiteres". :)
     
  16. Binser
    Offline

    Binser Well-Known Member

    Registriert seit:
    23. Mai 2013
    Beiträge:
    318
    Danke:
    287
    Handy:
    Xiaomi Mi Max, K3 Note, Alife S1, LG P500, Sony Xperia X8, Teclast X16 Pro, Nook ST, Fire TV, MK809 Plus, MK808B Plus
    So, jetzt noch die Ergebnisse meiner weiteren Untersuchungen mit Testdisk:

    HD1-11 [android_config]
    2 Folders:
    lost+found (empty)
    telephony

    Dateien in telephony:
    mmb_pid.txt (dort ist nur eine 4 stellige Zahl drin)
    static.nvm
    dynamic.nvm
    calib.nvm

    HD1-12 [android_factory]
    same folders as HD1-11, but both were empty

    Es scheint jetzt alles OK zu sein, und ich werde mit der weiteren Einrichtung Androids fortschreiten.

    Und ich werde vielleicht noch mal einen Anlauf nehmen, Xposed zu installieren.
     
    tommy0815 sagt Danke für diesen hilfreichen Beitrag.