1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen

Video-Anleitung NAND/NOR-Flash mit FlashTool v3.9.xxxx

Dieses Thema im Forum "Firmware-Flash-Tutorials" wurde erstellt von Rumpelstilzchen, 21. März 2010.

  1. NacktesBaerchen
    Offline

    NacktesBaerchen New Member

    Registriert seit:
    6. Juni 2011
    Beiträge:
    11
    Danke:
    0
    Handy:
    M98 Google 4GS+
    @ Rumpelstilzchen & Colonel Zapp

    Ich hab mir schon fast alle Haare ausgerissen...:

    Meine Daten:

    Handy:
    M98 Google 4GS+ ( http://www.fastcardtech.com/goods.php?id=5729 ) CPU: MT6516

    Problem:
    Startet bis zum ersten statischen ANDROID Splash Screen, keine tasten funktionieren. Es sein denn, ich drücke während dem Start PowerOn + VolumeUp... dann erscheint zusätzlich zum ANDROID-Logo der Schriftzug => Factory Mode im Display.

    Flashkabel:
    Sitecom USB to Serial Cable mit Prolific PL2303HX Chip. Treiber: Original Prolific PL2303 Driver. Kabel wird im Gerätemanager erkannt als Prolific USB to Serial Comm Port (COM17)

    Ich habe die Kabel des Klinkensteckers so angelötet:
    Rot Klinke -> Pin 2 Orange Serial Port male RXD
    Weiss Klinke -> Pin 3 Rot Serial Port male TXD
    GND Klinke -> Pin 5 Grün Serial Port male GND
    V+ hol ich direkt vom gleichen USB-Port in dem auch das Flashkabel steckt in den unteren Eingang des M98 (iPhone-Port)

    Laptop:
    Windows 7 Ultimate

    FlashTool V3.1108.00.00 Build Feb. 24 2011

    So... nun starte ich das Flash Tool als Admin... Stelle alles laut anweisung ein aber... kein readback, kein Flash... einfach nix. Was mache ich falsch?
     
    Zuletzt bearbeitet: 15. Juni 2011
  2. NacktesBaerchen
    Offline

    NacktesBaerchen New Member

    Registriert seit:
    6. Juni 2011
    Beiträge:
    11
    Danke:
    0
    Handy:
    M98 Google 4GS+
    Falls das hier im falschen Thread steht, bitte verschieben... hab mich hier noch nich so ganz durchgewurstet... danke...
     
  3. Rumpelstilzchen
    Offline

    Rumpelstilzchen Well-Known Member

    Registriert seit:
    21. Juli 2009
    Beiträge:
    5,595
    Danke:
    1,130
    Handy:
    Nexus 5
    Für mich nach wie vor unschlagbar :-)
    Erstens: dein Pinout stimmt nicht. Woher hast du die Daten?
    Zweitens: du nutzt das falsche Flashtool. Du brauchst das: click
    Drittens: du hast kein Nucleus MTK Handy, du hast ein Android Handy. Da ist kein Readback wie in dem Video möglich.
    Und auch der Flash geht anders. Bist hier somit eigentlich total falsch :hihihi:

    Hast du denn ne ROM für das M98?
     
  4. NacktesBaerchen
    Offline

    NacktesBaerchen New Member

    Registriert seit:
    6. Juni 2011
    Beiträge:
    11
    Danke:
    0
    Handy:
    M98 Google 4GS+
    Also erstmal danke, dass du antwortest...

    zu erstens: hab mich tagelang durch etliche Foren gebürstet und mir in etwa baugleiche Modelle und deren Flashanleitungen angeschaut. Den pinout habe ich von forum.gsmhosting.com.

    zu zweitens: ich habe einige Flashtools mit denen es "angeblich" funktionieren soll ausprobiert. Auch das, was du mir genannt hast. Aber keins bekommt auch nur annähernd eine verbindung zum phone. Kein Wunder, wenn der pinout falsch ist...hmm...

    zu drittens: aha... wieder schlauer...

    ich will erstmal überhaupt ne verbindung zum phone bekommen und nen readback machen wenns sinnvoll ist.
     
  5. Rumpelstilzchen
    Offline

    Rumpelstilzchen Well-Known Member

    Registriert seit:
    21. Juli 2009
    Beiträge:
    5,595
    Danke:
    1,130
    Handy:
    Nexus 5
    Für mich nach wie vor unschlagbar :-)
    Das ist der richtige Pinout:
    [​IMG]
    Und nimm als GND besser die 15.

    Und wie gesagt, ein Readback ist bei Android über FlashTool nicht möglich.
    Du kannst schon auslesen, aber nur binär. Ich nutze das immer um Flashkabel zu testen.
    Aber mit der Binären Datei kannst du halt nix anfangen.
    Zum Verbindung testen reicht es aber :)

    Das ist ne ROM für das M98: click
    Würde das aber mit Vorsicht genießen. Hab die selber nie getestet ;)
     
  6. NacktesBaerchen
    Offline

    NacktesBaerchen New Member

    Registriert seit:
    6. Juni 2011
    Beiträge:
    11
    Danke:
    0
    Handy:
    M98 Google 4GS+
    Okay... vielen Dank... flashen sollte aber dann auch mit dem tool möglich sein? Sofern ich ne verbindung bekomm... wie gesagt, nach den ersten Android-logo friert das phone ein. ausschalten nur, wenn ich den akku rausnehm.

    Äh... in welchem Thread wär ich denn eigentlich richtig?
     
  7. Rumpelstilzchen
    Offline

    Rumpelstilzchen Well-Known Member

    Registriert seit:
    21. Juli 2009
    Beiträge:
    5,595
    Danke:
    1,130
    Handy:
    Nexus 5
    Für mich nach wie vor unschlagbar :-)
    Um das zu beheben brauchst du aber kein Flashkabel :)
    Das Flashkabel brauchst du nur für den Bootloader.

    Starte mal das FlashTool das ich verlinkt habe.
    Einstellungen wie hier:
    [​IMG]
    Also nur die 3 Images aktivieren.

    Dann auf Download. Dann kommt unten rechts eine 5 Sekunden Aufforderung das Datenkabel einzustecken.
    Das einstecken. Dann wird nach Treibern gesucht.
    Das wären dann die da: click

    Wenn der Treiber installiert ist, dann flasht es die Images aufs Phone.

    Aber Vorsicht !!! Danach hast du keine IMEIs mehr.
    Dafür brauchst du dann das Flashkabel. Und das Tool, Anleitung ist dabei: click

    Und alles auf eigene Gefahr, gelle ;)
    Ich kenne die ROM nicht die du auf dem M98 hast. Ob die mit der von mir kompatibel ist.

    EDIT: eines noch. Wenn du beim einschalten die Volume up und Power gleichzeitig gedrückt hälst, kommst du dann ins Recovery Menü?
     
    Zuletzt bearbeitet: 15. Juni 2011
  8. NacktesBaerchen
    Offline

    NacktesBaerchen New Member

    Registriert seit:
    6. Juni 2011
    Beiträge:
    11
    Danke:
    0
    Handy:
    M98 Google 4GS+
    okay... also... da ich ein 64-bit system habe, werden die 32-bit treiber nicht akzeptiert. nu steh ich da...
     
  9. Rumpelstilzchen
    Offline

    Rumpelstilzchen Well-Known Member

    Registriert seit:
    21. Juli 2009
    Beiträge:
    5,595
    Danke:
    1,130
    Handy:
    Nexus 5
    Für mich nach wie vor unschlagbar :-)
    Die da probieren: click
    Und kommst du jetzt ins recovery?
     
  10. NacktesBaerchen
    Offline

    NacktesBaerchen New Member

    Registriert seit:
    6. Juni 2011
    Beiträge:
    11
    Danke:
    0
    Handy:
    M98 Google 4GS+
    Treiber installiert...

    EBOOT ERROR (9000)

    [Android] cannot find the USB Port...

    Leider noch keine verbindung...

    Nochwas... ich hab NUR die drei Kontakte TX, RX, und GND angeschlossen.
    Akku ist voll und eingelegt,
    Keine externe Stromquelle.
    Handy ist ausgeschaltet.
    Prolific2303 Treiber ist installiert.
    Bleibt nur zu hoffen, dass die Ausgänge am Serial Port richtig angeschlossen sind.
    Ist ein RS232 9-Pol anschluss von denen ich nur RX Pin 2, TX Pin 3 und GND Pin 5 nutze.
     
    Zuletzt bearbeitet: 16. Juni 2011
  11. Rumpelstilzchen
    Offline

    Rumpelstilzchen Well-Known Member

    Registriert seit:
    21. Juli 2009
    Beiträge:
    5,595
    Danke:
    1,130
    Handy:
    Nexus 5
    Für mich nach wie vor unschlagbar :-)
    Dann ist der Treiber immer noch nicht installiert.
    Du hast das Handy aus, beim 5 Sekunden Timing das Datenkabel (nicht Flashkabel !!!) einstecken.
    Dann sollte dein PC nach Treibern suchen.


    Du nutzt ne RS232 Schnittstelle? Was willst du dann mit dem Prolific Treiber?
    Der PL2303 ist ein USB to TTL Pegelwandler.
    Siehe da: click
    Du kannst nicht die RS232 Pegel nutzen. Das ist kein LV-TTL (3.3VDC). Und genau den brauchst du.
     
    Zuletzt bearbeitet: 16. Juni 2011
  12. NacktesBaerchen
    Offline

    NacktesBaerchen New Member

    Registriert seit:
    6. Juni 2011
    Beiträge:
    11
    Danke:
    0
    Handy:
    M98 Google 4GS+
    Nun... das ist ein USB to Serial Cable mit einem Prolific 2303HX Chip. Der originale treiber ist der gleiche.

    Soooo... das Phone startet wieder... der Bootloader wars also. IMEIs sind noch da.

    Scheint ein ROM von einem HTC zu sein... jedenfalls sind im FactoryMode bei den testmodes die typischen 3 tasten unterm touch anzusteuern.

    Beim Starten mit PowerUP + VolumeUP komme ich in den FactoryMode, nicht jedoch in den RecoveryMode :( ... Wäre schön, wenn ich da hin kommen würde... dann könnte ich die update.zip von FCT einspielen.

    Das Kabel war das Problem denk ich. Ich hatte versucht, mit dem Flashkabel im tool zu booten, nicht mit dem Datenkabel.
    so weit, so gut... jetzt noch durchs menü kämpfen und auf deutsch umstellen...
     
    Zuletzt bearbeitet: 16. Juni 2011
  13. Rumpelstilzchen
    Offline

    Rumpelstilzchen Well-Known Member

    Registriert seit:
    21. Juli 2009
    Beiträge:
    5,595
    Danke:
    1,130
    Handy:
    Nexus 5
    Für mich nach wie vor unschlagbar :-)
    Na dann hat sich der Post ja erledigt wenn es wieder geht.
    Und ja, hatte ich ja gesagt. Nicht das Flashkabel nutzen, das Datenkabel in dem Fall.
    Das Flashkabel brauchst du nur für den Bootloader.

    Und Bitteschön ;)
     
    Zuletzt bearbeitet: 16. Juni 2011
  14. NacktesBaerchen
    Offline

    NacktesBaerchen New Member

    Registriert seit:
    6. Juni 2011
    Beiträge:
    11
    Danke:
    0
    Handy:
    M98 Google 4GS+
    tja... erst lesen dann handeln hat mama damals schon immer gesagt...

    wenn du mir zu guter letzt noch verrätst, wie ich wieder den recoverymode aktivieren kann, komm ich zu dir und knutsch dich... oder gibts noch ne andere methode das update zu installieren?
     
  15. ColonelZap
    Offline

    ColonelZap Administrator Mitarbeiter

    Registriert seit:
    9. April 2008
    Beiträge:
    24,825
    Danke:
    8,077
    Geschlecht:
    männlich
    Handy:
    Xiaomi Mi4
    Na, da hilft man doch GERNE ;)
     
  16. Rumpelstilzchen
    Offline

    Rumpelstilzchen Well-Known Member

    Registriert seit:
    21. Juli 2009
    Beiträge:
    5,595
    Danke:
    1,130
    Handy:
    Nexus 5
    Für mich nach wie vor unschlagbar :-)
    Hättest besser mehr auf Mama gehört :hihihi:

    Die Tastenkombi beim M98 kenne ich nicht.
    Aber hol dir doch die "kleine SDK" Version auf den PC.
    Dann das Handy via ADB verbinden.

    CMD.exe starten.
    Eingabe: adb shell reboot recovery
    Fertig :)
     
  17. NacktesBaerchen
    Offline

    NacktesBaerchen New Member

    Registriert seit:
    6. Juni 2011
    Beiträge:
    11
    Danke:
    0
    Handy:
    M98 Google 4GS+
    die sdk hab ich noch... isch probiere und berichte... moooooment...

    Ergebnis...

    SDK hat Zugriff aufs phone... Nach der Eingabe von adb shell reboot recovery bootet das gerät neu... oder versuchts zumindest. Bleibt aber beim allerersten ANDROID- Schriftzug stehen. Nix geht mehr. Batterie raus, normal booten funzt. Hat jemand ne Idee ? Ich komm nich ins Recovery Menü rein.
     
    Zuletzt bearbeitet: 16. Juni 2011
  18. Rumpelstilzchen
    Offline

    Rumpelstilzchen Well-Known Member

    Registriert seit:
    21. Juli 2009
    Beiträge:
    5,595
    Danke:
    1,130
    Handy:
    Nexus 5
    Für mich nach wie vor unschlagbar :-)
    Versuch mal die Home + Power Taste gleichzeitig gedrückt zu halten.
     
  19. NacktesBaerchen
    Offline

    NacktesBaerchen New Member

    Registriert seit:
    6. Juni 2011
    Beiträge:
    11
    Danke:
    0
    Handy:
    M98 Google 4GS+
    Funktioniert... erstmal...

    aber erst nachdem ich die recovery.img auch aufgespielt hab...

    sooo... aber... wenn ich install from sd-card:update.zip anwähle: Install update... Installation aborted

    nix klappt mal flüssig... mann ey...
     
  20. Rumpelstilzchen
    Offline

    Rumpelstilzchen Well-Known Member

    Registriert seit:
    21. Juli 2009
    Beiträge:
    5,595
    Danke:
    1,130
    Handy:
    Nexus 5
    Für mich nach wie vor unschlagbar :-)
    Dann brauchst du ein alternatives Recovery. Das 3e von Froyo ist Sch*****
    Mach mich da heute Mittag mal auf die Suche. Sollte aufzutreiben sein :)