1. Diese Seite verwendet Cookies. Wenn du dich weiterhin auf dieser Seite aufhältst, akzeptierst du unseren Einsatz von Cookies. Weitere Informationen
  2. Made4you.lu - Dein persönliches Geschenk!
    Information ausblenden

X18i Tasten Problem

Dieses Thema im Forum "Firmware, rooten, etc." wurde erstellt von dorschdns, 20. April 2012.

  1. dorschdns
    Offline

    dorschdns ClonePhone Facharzt

    Registriert seit:
    15. Oktober 2009
    Beiträge:
    2,057
    Danke:
    1,687
    Geschlecht:
    männlich
    Handy:
    Oukitel U10
    Cubot X9
    INEW V3
    Doogee Turbo2014
    GT-I9500 1micro Sim
    H868
    I5C
    Hallo,
    Ich habe mir ein gut gebrauchtes X18i zugelegt, bei dem höchstwahrscheinlich durch das Rooten und dem damit verbundenen aufspielen neuer boot.img und uboot.img
    die richtigen Treiber für die drei Tasten nicht mehr vorhanden sind.
    Hardwareseitig dürften die Tasten in Ordnung sein, das habe ich mit dem Hardwaretest (power und Volumen-) getestet.
    Hat von Euch jemand eine Idee wie ich die Tasten wieder zum Leben erwecken könnte?
    Bitte Bitte Bitte helft mir :)
    dorschdn
     
  2. dorschdns
    Offline

    dorschdns ClonePhone Facharzt

    Registriert seit:
    15. Oktober 2009
    Beiträge:
    2,057
    Danke:
    1,687
    Geschlecht:
    männlich
    Handy:
    Oukitel U10
    Cubot X9
    INEW V3
    Doogee Turbo2014
    GT-I9500 1micro Sim
    H868
    I5C
    Ich hab jetzt festgestellt, dass bei gedrückter Power Taste diese drei unteren Tasten einwandfrei funktionieren.
    Also dürfte es sich doch nicht um ein Treiber Problem handeln.
    Was kann das sein? Wie kann ich den Fehler beheben?
    dorschdn
     
  3. MomoFab
    Offline

    MomoFab Member

    Registriert seit:
    25. Dezember 2011
    Beiträge:
    348
    Danke:
    4
    Handy:
    Star X18i 3G
    Hi dorschdns,

    ja, klingt nach Soft-Fehler. Schon eine Original-Firmware geflasht?

    Wenn nicht, im Download-Bereich habe ich eine 2.3.4 für das x18i vor längerem hochgeladen.

    MomoFab.
     
  4. dorschdns
    Offline

    dorschdns ClonePhone Facharzt

    Registriert seit:
    15. Oktober 2009
    Beiträge:
    2,057
    Danke:
    1,687
    Geschlecht:
    männlich
    Handy:
    Oukitel U10
    Cubot X9
    INEW V3
    Doogee Turbo2014
    GT-I9500 1micro Sim
    H868
    I5C
    Hallo MomoFab,
    ich bin hier wiedermal am verzweifeln, das Teil hat derjenige von dem ich es erstanden hab angeblich so wie es ist im Cect-Shop gekauft. Das Phone war gerootet und bereits geöffnet, Schrauben waren fehlerhaft eingesetzt, siegel war kaputt.....im Simkarteneinschub sind die Kontakte total verbogen......
    Danke für den Tipp, die Software werd ich mir gleich laden, ich berichte dann weiter.
     
  5. MomoFab
    Offline

    MomoFab Member

    Registriert seit:
    25. Dezember 2011
    Beiträge:
    348
    Danke:
    4
    Handy:
    Star X18i 3G
    Puahh! Das ist natürlich bitter...

    Mit allen Häkchen ausser die beiden Ersten bei SPFlashTool, flashe mal die x18i 2.3.4 Original-Firmware.
    Ist allerdings die Firm mit den China-Apps!
    Wenn aber dafür deine Tasten wieder funktionieren... kannst ja anschließend updaten.

    MomoFab.
     
  6. dorschdns
    Offline

    dorschdns ClonePhone Facharzt

    Registriert seit:
    15. Oktober 2009
    Beiträge:
    2,057
    Danke:
    1,687
    Geschlecht:
    männlich
    Handy:
    Oukitel U10
    Cubot X9
    INEW V3
    Doogee Turbo2014
    GT-I9500 1micro Sim
    H868
    I5C
    Die hab ich auch schon probiert, danke dir Momofab, diese ist aber über SD Card zu flashen!
     
  7. MomoFab
    Offline

    MomoFab Member

    Registriert seit:
    25. Dezember 2011
    Beiträge:
    348
    Danke:
    4
    Handy:
    Star X18i 3G
    Oops! Du hast recht...

    Ich suche mal eben eine zum Flashen...

    MomoFab.
     
  8. dorschdns
    Offline

    dorschdns ClonePhone Facharzt

    Registriert seit:
    15. Oktober 2009
    Beiträge:
    2,057
    Danke:
    1,687
    Geschlecht:
    männlich
    Handy:
    Oukitel U10
    Cubot X9
    INEW V3
    Doogee Turbo2014
    GT-I9500 1micro Sim
    H868
    I5C
    Ach Momofab, vielen vielen Dank :)
    Ich hab jetzt so ziemlich alles geflasht, was es im Downloadbereich zu laden gibt.
    Alles mit dem gleichen Ergebnis.
    Wenn ich die Powertaste zusammen mit einer von den drei tasten drücke funktioniert diese Taste.
    Das ist wie verhext. :)
     
  9. MomoFab
    Offline

    MomoFab Member

    Registriert seit:
    25. Dezember 2011
    Beiträge:
    348
    Danke:
    4
    Handy:
    Star X18i 3G
    Das müsste ein ROM zum Aufspielen mit dem SPFlashToo seinl: HIER
     
    Zuletzt bearbeitet: 21. April 2012
  10. dorschdns
    Offline

    dorschdns ClonePhone Facharzt

    Registriert seit:
    15. Oktober 2009
    Beiträge:
    2,057
    Danke:
    1,687
    Geschlecht:
    männlich
    Handy:
    Oukitel U10
    Cubot X9
    INEW V3
    Doogee Turbo2014
    GT-I9500 1micro Sim
    H868
    I5C
    Danke Momofab, das eine probier ich noch, dann machen wir aber Feierabend :) Du schlägst dir hier die Nacht um die Ohren.
    Das lädt.... und lädt ... und lädt .... :)

    Momofab, vielen Dank für deine Mühe, es hat sich leider nichts geändert.
    Ich mach nun Feierabend, gute Nacht.
    Danke Danke Danke! :)
     
    Zuletzt bearbeitet: 21. April 2012
  11. MomoFab
    Offline

    MomoFab Member

    Registriert seit:
    25. Dezember 2011
    Beiträge:
    348
    Danke:
    4
    Handy:
    Star X18i 3G
    Schade... mal sehen wie´s weitergeht... gute Nacht.

    MomoFab.
     
  12. dorschdns
    Offline

    dorschdns ClonePhone Facharzt

    Registriert seit:
    15. Oktober 2009
    Beiträge:
    2,057
    Danke:
    1,687
    Geschlecht:
    männlich
    Handy:
    Oukitel U10
    Cubot X9
    INEW V3
    Doogee Turbo2014
    GT-I9500 1micro Sim
    H868
    I5C
    Guten Morgen alle zusammen,

    ich werde mich wohl oder übel damit abfinden, dass ich diese drei tasten zusammen mit der Power Taste drücken muß.

    Vielen Dank nochmal für Eure Hilfe.
     
  13. dorschdns
    Offline

    dorschdns ClonePhone Facharzt

    Registriert seit:
    15. Oktober 2009
    Beiträge:
    2,057
    Danke:
    1,687
    Geschlecht:
    männlich
    Handy:
    Oukitel U10
    Cubot X9
    INEW V3
    Doogee Turbo2014
    GT-I9500 1micro Sim
    H868
    I5C
    Für alle, die das "gleiche Schicksal" getroffen hat und auf dem Handy bestimmte Hardwaretasten nicht mehr ihren Ursprungsfunktionen entsprechen,
    es gibt eine Lösung! :)
    Getreu dem Motto "Es gibt für alles eine App" ist es auch hier so!.....
    Man installiert sich das hier: Button Savior (Root) - Android Apps auf Google Play
    konfiguriert es ein wenig und schon hat man die vermissten Funktionen wieder auf seinem Handy.
    Tolle Sache .....find ich!
    Gruß Dorschdn
     
  14. dorschdns
    Offline

    dorschdns ClonePhone Facharzt

    Registriert seit:
    15. Oktober 2009
    Beiträge:
    2,057
    Danke:
    1,687
    Geschlecht:
    männlich
    Handy:
    Oukitel U10
    Cubot X9
    INEW V3
    Doogee Turbo2014
    GT-I9500 1micro Sim
    H868
    I5C
    Ich hab keine Ahnung was pasiert ist, aber seit heut funktionieren die drei Hardware buttons auf meinem X18i wieder so wie sie sollen.

    Seltsam :)
    Dorschdn
     
  15. kkrriissii
    Offline

    kkrriissii Weiß Bescheid

    Registriert seit:
    25. Mai 2010
    Beiträge:
    230
    Danke:
    3
    Handy:
    Samsung Ativ S 16gb (Windows Phone 8)
    IP5-Clone vom Fuchs
    13" MacBook Unibody Weiß (Late 2009)
    Na dann... Viel Spaß weiterhin mit diesem tollen Handy ;)
     
  16. dorschdns
    Offline

    dorschdns ClonePhone Facharzt

    Registriert seit:
    15. Oktober 2009
    Beiträge:
    2,057
    Danke:
    1,687
    Geschlecht:
    männlich
    Handy:
    Oukitel U10
    Cubot X9
    INEW V3
    Doogee Turbo2014
    GT-I9500 1micro Sim
    H868
    I5C
    :)
    Hallo kkrriissii, :)
    Vielen Dank :Mauridia:
     
  17. dorschdns
    Offline

    dorschdns ClonePhone Facharzt

    Registriert seit:
    15. Oktober 2009
    Beiträge:
    2,057
    Danke:
    1,687
    Geschlecht:
    männlich
    Handy:
    Oukitel U10
    Cubot X9
    INEW V3
    Doogee Turbo2014
    GT-I9500 1micro Sim
    H868
    I5C
    Ich hab jetzt festgestellt, wenn ich das Handy mit der Button Savior App im Autostart starte, dann funktionieren alle Tasten am Handy.
    Starte ich das Handy ohne diese App im Autostart, dann funktionieren die Tasten nur in Verbindung mit der Power Taste.
    Hat evtl. jemand eine Erklärung dafür?
    Danke Dorschdns
     
  18. MomoFab
    Offline

    MomoFab Member

    Registriert seit:
    25. Dezember 2011
    Beiträge:
    348
    Danke:
    4
    Handy:
    Star X18i 3G
    Hi dorschdns,

    keine Erklärung dafür... aber das heißt, dass deine Hardware in Ordnung ist und es nur an der Software liegen kann. kurz noch die Nachfrage: hattest du beim Flaschen mit SPFlashTool auch alle Häkchen ausser die beiden Ersten gesetzt? Magst du es mit einem weiterem ROM ausprobieren? Was hast du zu verlieren...

    HIER massenhaft ROMs für´s x18i, öffne den Spoiler unter SP_Flash_Tool.

    Gruß, MomoFab.
     
  19. dorschdns
    Offline

    dorschdns ClonePhone Facharzt

    Registriert seit:
    15. Oktober 2009
    Beiträge:
    2,057
    Danke:
    1,687
    Geschlecht:
    männlich
    Handy:
    Oukitel U10
    Cubot X9
    INEW V3
    Doogee Turbo2014
    GT-I9500 1micro Sim
    H868
    I5C
    Hi Momo,
    Guten Morgen alle zusammen,
    Ja, ich hatte alle Häkchen gesetzt bis auf die beiden oberen und das Recovery.
    Frag mich bitte nicht, was ich gemacht habe, aber jedenfalls funktionieren diese bekl.....n Tasten nun wieder nicht mehr.
    Der von Dir angegebene Link führt mich auf eine Seite, wo mir angezeigt wird, dass ich keine Berechtigung besitze.
    Ich geb die Hoffnung langsam auf, dass diese Tasten jemals funktionieren werden. Das ist ja wie im Hexenhaus.
    Gibte es im Engineer Mode keine Möglichkeit diese Tasten einzustellen?
    Ich hab nun schon -zig Roms geflasht mit FlashTool und per Recovery über SDCard.
    Da kann es doch bald nur ein Hardwaredefekt sein.
    Ansonsten würde das gleich doch auch bei anderen X18i's auftreten.
    Gibt es eine Möglichkeit das Phone "vollkommen leer" zu machen, so dass überhaupt nichts mehr an Software vorhanden ist,
    so dass es vollkommen neu geflasht werden kann, ohne dass da irgendwo noch reste von alten Treiberdaten evtl vorhanden sind?
    Dorschdn
     
  20. MomoFab
    Offline

    MomoFab Member

    Registriert seit:
    25. Dezember 2011
    Beiträge:
    348
    Danke:
    4
    Handy:
    Star X18i 3G
    Guten Morgen dorschdns,

    im Engineer-Mode habe ich für die Tastenbelegung nichts zum einstellen gefunden. Im Factory-Mode (Vol- und Power) unter "Item Test" > "Keys" lassen sich die Tasten überprüfen, aber das hast du glaube ich schon gemacht ... wenn der Test erfolgreich ist, dann ist die Hardware in Ordnung.
    Das Handy "ganz leer machen": puhh! weiß nicht genau. Im Factory ist glaube ich was, habe es aber nie probiert, auf eigene Gefahr: "clear Flash".

    Hab den Link noch mal überprüft, die Seite ist offen, die Downloads auch, aber HIER der Link zur letzten 2.3.4 vom 31.12.2011.

    Gib nicht auf, das muss doch funktionieren...

    Gruß, MomoFab.